StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Issues after upgrade to Version V8, build 13279 (24 October

Pure software-based VM-centric and flash-friendly VM storage (iSCSI, SMB3, NFS, iSER and NVMe over Fabrics) including free version. Same software embedded on StarWind ready nodes.

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Issues after upgrade to Version V8, build 13279 (24 October

Postby bkdilse » Fri Nov 29, 2019 3:00 pm

Hi,

Upgraded my 2 node free Storage nodes to latest version, and now they loose Sync.
Yesterday they became unsynch'd

Today same thing.

I can see this in the log:

Srv: *** iScsiServer::listenConnections: *LICENSE* Rejected iSCSI connection to x.x.x.x:3260 from x.x.x.x:52853.Maximum of 0 allowed clients already connected to the server!

EDIT: Just checked previous logs (prior to yesterday), and there are no License errors.

What's going on, should I regress to previous version?
Any fix for this?
This is pretty bad !
bkdilse
 
Posts: 52
Joined: Mon Sep 10, 2018 6:14 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby bkdilse » Sat Nov 30, 2019 10:34 am

Time to regress then...
bkdilse
 
Posts: 52
Joined: Mon Sep 10, 2018 6:14 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby Boris (staff) » Tue Dec 03, 2019 11:59 am

Did both hosts lose sync or just one of them?
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby bkdilse » Tue Dec 03, 2019 12:13 pm

Boris (staff) wrote:Did both hosts lose sync or just one of them?


Both, every 24h.
bkdilse
 
Posts: 52
Joined: Mon Sep 10, 2018 6:14 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby Boris (staff) » Tue Dec 03, 2019 12:40 pm

Looks like an issue with licensing. What build gives you this issue?
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby bkdilse » Tue Dec 03, 2019 12:44 pm

Boris (staff) wrote:Looks like an issue with licensing. What build gives you this issue?


The one in the subject :) Version V8, build 13279 (24 October 2019)
bkdilse
 
Posts: 52
Joined: Mon Sep 10, 2018 6:14 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby Boris (staff) » Tue Dec 03, 2019 1:03 pm

Sorry, totally missed it...
Could you collect logs from your hosts using StarWind Log Collector and share them with me? Do not forget to send your license file used there, too.
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby bkdilse » Tue Dec 03, 2019 1:08 pm

Boris (staff) wrote:Sorry, totally missed it...
Could you collect logs from your hosts using StarWind Log Collector and share them with me? Do not forget to send your license file used there, too.


I've actually regressed back to 2 versions being. And flush the log directory after confirming it all work (mistake, as I had loads of space).
bkdilse
 
Posts: 52
Joined: Mon Sep 10, 2018 6:14 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby Boris (staff) » Tue Dec 03, 2019 1:34 pm

Well... At least I believe it works for you now, right?
If you ever try upgrading to the next builds and get the same reproduced just keep this thread in mind. We will definitely want to check the logs on our side. This particular build was supposed to resolve the issue, yet you are the second person reporting it did not.
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby bkdilse » Tue Dec 03, 2019 1:40 pm

Boris (staff) wrote:Well... At least I believe it works for you now, right?
If you ever try upgrading to the next builds and get the same reproduced just keep this thread in mind. We will definitely want to check the logs on our side. This particular build was supposed to resolve the issue, yet you are the second person reporting it did not.


Sure will do.
bkdilse
 
Posts: 52
Joined: Mon Sep 10, 2018 6:14 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby Boris (staff) » Fri Dec 06, 2019 11:52 am

Thanks in advance.
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby jimtheITguy » Sat Dec 21, 2019 10:53 am

Just to report I have experienced the same issue on a 2 node VSAN Free, might be worth sticking a link up to a previous version just incase as had to go hunting for a version to roll back to
jimtheITguy
 
Posts: 1
Joined: Sat Dec 21, 2019 10:50 am

Re: Issues after upgrade to Version V8, build 13279 (24 October

Postby Michael (staff) » Fri Dec 27, 2019 11:18 pm

Hello jimtheITguy,
Could you please share the logs with us?
Please use the log collector from this KB article: https://knowledgebase.starwindsoftware. ... collector/
Michael (staff)
Staff
 
Posts: 305
Joined: Thu Jul 21, 2016 10:16 am


Return to StarWind Virtual SAN / StarWind Virtual SAN Free / StarWind HyperConverged Appliance / StarWind Storage Appliance

Who is online

Users browsing this forum: No registered users and 4 guests