StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Licence rejected

Pure software-based VM-centric and flash-friendly VM storage (iSCSI, SMB3, NFS, iSER and NVMe over Fabrics) including free version. Same software embedded on StarWind ready nodes.

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Licence rejected

Postby BenM » Mon Dec 16, 2019 8:00 am

Guys

Up October 2018 release to current release on Friday PM. Everything went normally./

Come in to work this morning, and cluster is down.... look in Starwind logs and see

12/16 1:24:43.133005 1a50 Srv: *** iScsiServer::listenConnections: *LICENSE* Rejected iSCSI connection to 192.168.203.1:3260 from 192.168.203.2:58913.Maximum of 0 allowed clients already connected to the server!

At the top....

Rather than break anything by rebooting indescriminately I am asking here for help!

Someone else (i think) had an issue with licenses and updates, however I don';t recall at the moment which thread it was!

Please help...


Ben
BenM
 
Posts: 28
Joined: Wed Oct 24, 2018 7:17 am

Re: Licence rejected

Postby BenM » Mon Dec 16, 2019 8:38 am

HI again

Initial craziness from users fielded I can be a little more rational.

I do remember reading a thread saying that someone else had the issue and that they reverted their copy of SW... I am not really keen to do that.

Update went smothly - moved all roles to one node, paused the other, updated the paused node, waited till data said Synchronised in Stawrwind Console, un-pause the node and fail back roles. Move other roles onto newley updated node. Pause the other down level node, update, wait for Sync/normal function, unpause and fail back. Result was everything working as expected - no visible StarWind errors at that time. Checked starwind logs for the error that the other user reported, just in case.

When I left on Friday both nodes said synchronised and functioning normally.

Get in this morning and users are unable to connect to anything. All roles saved or failed in FOCM

Checked the network back to the server room from a typical PC... no infrastructure issues.

Logged in to one host, checked StarWind logs and spotted, right at the top, the error.

I have collected the StarWind logs from both servers and can send them to whoever wants to catch this plea for help!

Ben
BenM
 
Posts: 28
Joined: Wed Oct 24, 2018 7:17 am

Re: Licence rejected

Postby Boris (staff) » Mon Dec 16, 2019 8:55 am

Most likely you were hit by the issue with trail license expiration check. I would like to request logs from your system to check this additionally. For now the workaround is to downgrade to build 12767 or 12658 depending on which of them you used before the update.
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: Licence rejected

Postby BenM » Mon Dec 16, 2019 8:57 am

Ok - as soon as I can get my g-Drive back, they will be where they were last time!

Ben
BenM
 
Posts: 28
Joined: Wed Oct 24, 2018 7:17 am

Re: Licence rejected

Postby BenM » Mon Dec 16, 2019 9:02 am

Hi Boris

The zip files are where they were last time, would you like me to PM the link?

Also - to down grade to the previous version, I guess I just pause the node, don't try to drain the roles and then run the install as usual?

I assume SW will sort out which drive has the latest data for Sync or do I have to play "find the most recent" again?

Ben
BenM
 
Posts: 28
Joined: Wed Oct 24, 2018 7:17 am

Re: Licence rejected

Postby BenM » Mon Dec 16, 2019 9:52 am

Ok that seems to have worked - up to a point.

The CSV has come back - its Synchronising. Can I bring roles back online on the node with the up to date data?

The Witness hasn't survived - both nodes say device is not synchronised. Do I force it synchronised (on the host which has the most recent CSV, assuming it was the most recent Witness as well) or just wait to see what it does in a while?

Ben
BenM
 
Posts: 28
Joined: Wed Oct 24, 2018 7:17 am

Re: Licence rejected

Postby yaroslav (staff) » Mon Dec 16, 2019 10:28 am

Yes, you need to force-start the synchronization of the Witness disk. Yes, feel free to bring the roles up on the node which carries the most up-to-date data. Performance might be mediocre due to synchronization but at least the production stays operational.
yaroslav (staff)
Staff
 
Posts: 106
Joined: Mon Nov 18, 2019 11:11 am

Re: Licence rejected

Postby yaroslav (staff) » Mon Dec 16, 2019 10:32 am

Here is the guide on how to re-install StarWind VSAN without compromising the uptime of your environment: https://knowledgebase.starwindsoftware. ... d-version/

Did you mark any node as synchronized after studying the log or did the synchronization start on its own?

P.S. Witness does not carry any data, so feel free to mark it synchronized on the node which carries the latest data.
yaroslav (staff)
Staff
 
Posts: 106
Joined: Mon Nov 18, 2019 11:11 am

Re: Licence rejected

Postby BenM » Mon Dec 16, 2019 11:25 am

Yaroslav

Thanks for the guide.

Starwind brought the CSV up and started synchronizing on its own after i installed the old version of SW on the hosts - I have not (yet) marked anything as synchronised manually. The host that has the older data I have kept paused in the cluster.

I have moved roles back to the up node and started them all (plenty of RAM for that; IO? not so much!) As you say, the performance is mediocre - however some service for the users is better than none! There remain a few network config issues with the guests related to their restarts but no blue screens or major issues.

Thanks for all your (and Boris') help

Ben
BenM
 
Posts: 28
Joined: Wed Oct 24, 2018 7:17 am

Re: Licence rejected

Postby yaroslav (staff) » Mon Dec 16, 2019 11:41 am

No worries, it sometimes happens that StarWind marks the site with the newest data. Feel free to mark the Witness as synchronized.
We are always here to help you.
yaroslav (staff)
Staff
 
Posts: 106
Joined: Mon Nov 18, 2019 11:11 am


Return to StarWind Virtual SAN / StarWind Virtual SAN Free / StarWind HyperConverged Appliance / StarWind Storage Appliance

Who is online

Users browsing this forum: No registered users and 2 guests