StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Very Slow Performance on Hyper-V

Tape drive and auto-loader redirector (iSCSI)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Very Slow Performance on Hyper-V

Postby faberphoto » Thu Jan 17, 2019 9:33 am

Hello!
I'm facing a performance problem with my implementation of Tape library.
My environment:
- hyper-v Host that physically connects the HP tape library and provides iSCSI connection to my LAN
- hyper-v Guest (on the same host) that uses the tape library, running DPM 2016 UR6

The guest and the host are connected thru the virtual switch and the network bandwidth is 10 Gb

The problem is that when the guest sends the data to the tape, the network used is about 400mbps and the backups are very slow, so slow that it takes more than 24 hours to complete

I've applied some tricks on the network (jumbo frames end so on) but without luck. The DPM server is able to go faster that 4 Gb during the backup-to-disk so I don't think to have big network issues.

Is there something that I can check or modify to get my iSCSI connection go faster?
thank you!
faberphoto
 
Posts: 2
Joined: Thu Jan 17, 2019 9:25 am

Re: Very Slow Performance on Hyper-V

Postby Boris (staff) » Fri Jan 18, 2019 5:14 pm

As far as I get it, you use a physical tape library and StarWind Tape Redirector. Could you confirm this?
If the above assumption is correct, what is the model of your tape library and what is the type of LTO tapes you are using?

As for
the network used is about 400mbps

could you specify whether you meant 400MB/s or 400Mbit/s?

What is the OS edition installed inside the VM where DPM is installed? In case it is Windows 2016, double check that Windows Defender is disabled.

Using iperf, check the network throughput between the physical host and the DPM VM.
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: Very Slow Performance on Hyper-V

Postby faberphoto » Mon Jan 21, 2019 9:45 am

your assumptions are correct.
the tape library is HP Autoloader 8/8 and it is attached thru SAS to the Hyper-V host. On the host I've installed tape redirector and published the library theu iSCSi. On the hyper-v guest I've configured DPM to use the library.
The speed is in megabits per second, and not megabytes
The VM is Windows 2016 and Defender is disabled

iperf tell me that the network is able to get 2.5 gbps (quite slower than I thought), so I think that 400mbps has still come room to grow. is not?
faberphoto
 
Posts: 2
Joined: Thu Jan 17, 2019 9:25 am

Re: Very Slow Performance on Hyper-V

Postby Oleg(staff) » Wed Jan 23, 2019 2:13 pm

Could you please check these troubleshooting steps?

Also, could you please provide us with the following information:
iperf tell me that the network is able to get 2.5 gbps

Is that teamed connection? What is network adapters vendor? Do you have Jumbo frames enabled, VMQ parameter enabled/disabled on the adapters which are in use for the VM connection?
Did you check read and copy speed from the backup files location?
Oleg(staff)
Staff
 
Posts: 567
Joined: Fri Nov 24, 2017 7:52 am

Re: Very Slow Performance on Hyper-V

Postby Jess_ss » Wed Mar 18, 2020 1:00 pm

A list of 20 tweaks which can be used to optimize and improve VM performance in a Hyper-V environment:

Enable Hyper-V Integration Services
Use fixed VHD files
Don’t use Hyper-V snapshots as a Hyper-V backup alternative
Configure the size of paging files
Do not create too many virtual network switches
Avoid overloading the management OS
Close unnecessary applications
Install Hyper-V on Windows Server Core
Determine a performance baseline
Allocate resources effectively
Enable Multipath I/O
Use the Dynamic Memory Feature
Enable VLAN tagging
Defragment virtual hard disks
Ensure that your hardware is certified
Use RAID 10 volumes
Deploy 64-bit guest OSs and Generation 2 VMs
Properly configure your anti-virus
Organize busy VMs into separate volumes
Automate tasks with PowerShell cmdlets

More here: https://www.nakivo.com/blog/top-20-tips ... ce-hyper-v
Jess_ss
 
Posts: 2
Joined: Fri Mar 13, 2020 2:14 pm

Re: Very Slow Performance on Hyper-V

Postby yaroslav (staff) » Wed Mar 18, 2020 1:02 pm

Thank you for sharing the knowledge with others.
yaroslav (staff)
Staff
 
Posts: 120
Joined: Mon Nov 18, 2019 11:11 am


Return to StarWind Tape Redirector

Who is online

Users browsing this forum: No registered users and 0 guests