StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Tape redirector setup issue

Tape drive and auto-loader redirector (iSCSI)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Tape redirector setup issue

Postby pmsadmin » Wed Aug 13, 2014 5:32 pm

System info:
Vmware 5.5 host with a SAS card
Dell TL2000 Tape library
VM os Windows 2012 R2

When I run the Add device wizard, and select Export tape auto-loader/changer device, I can select the auto-loader but in the next step, there is no device in the select tape drive windows. I can see both the drive and the library in device manager and I have tested the library using Veeam with success. Tape redirector was installed on a VM running Windows 2012 R2 and I have also tried using a windows 2008 R2 with the same problem. What am I missing?

Regards,
pmsadmin
 
Posts: 5
Joined: Wed Aug 13, 2014 5:01 pm

Re: Tape redirector setup issue

Postby Anatoly (staff) » Thu Aug 14, 2014 8:09 am

We would really appreciate if you could drop us the screenshots, so we could try to reproduce the issue in our lab.
Also it would be really great if you could grab the StarWind log on the moment of the issue, upload it to some file hosting and share the link with us.

Thank you
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am

Re: Tape redirector setup issue

Postby pmsadmin » Thu Aug 14, 2014 1:14 pm

I have uploaded the print screen as attachement along with the logs. Thanks for the help.

device manager.png
Device manager showing drive and library.
device manager.png (59.6 KiB) Viewed 31329 times
Attachments
starwind-20140813-124314.zip
Tape redirector logs.
(4.65 KiB) Downloaded 1023 times
tape drive selection.png
Choosing tape drive. Empty list.
tape drive selection.png (56.54 KiB) Viewed 31329 times
pmsadmin
 
Posts: 5
Joined: Wed Aug 13, 2014 5:01 pm

Re: Tape redirector setup issue

Postby pmsadmin » Thu Aug 14, 2014 1:17 pm

Here is the other print screen showing the library in the Add device wizard. As you can see, I can select the library but there are no tape drive to choose from. But both the tape drive and the library are present in device manager.
Attachments
library selection.png
Library selection.
library selection.png (80.94 KiB) Viewed 31329 times
pmsadmin
 
Posts: 5
Joined: Wed Aug 13, 2014 5:01 pm

Re: Tape redirector setup issue

Postby Anatoly (staff) » Thu Aug 14, 2014 5:53 pm

OK, thanks!
We investigating it. I`ll get back to you as soon as we`ll have anything.
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am

Re: Tape redirector setup issue

Postby Anatoly (staff) » Fri Aug 15, 2014 1:23 pm

OK, we`ve got workaround for you.
Can you try to configure get all the tapes and changer as the multi-LUN device?
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am

Re: Tape redirector setup issue

Postby pmsadmin » Mon Aug 18, 2014 11:34 am

Not sure how to configure the tape and media changer as a multi-LUN device. Where do you configure this and how?
pmsadmin
 
Posts: 5
Joined: Wed Aug 13, 2014 5:01 pm

Re: Tape redirector setup issue

Postby Anatoly (staff) » Thu Aug 21, 2014 8:36 am

In StarWind management console add one target, and then using the right-click option "Add new device to target" add your two devices. thus you will attach two devices to one target. Let me know if it did not work.
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am

Re: Tape redirector setup issue

Postby pmsadmin » Thu Aug 21, 2014 3:41 pm

It does not work. Getting this error.

Error.png
Error.png (26.81 KiB) Viewed 31295 times
pmsadmin
 
Posts: 5
Joined: Wed Aug 13, 2014 5:01 pm

Re: Tape redirector setup issue

Postby Anatoly (staff) » Wed Aug 27, 2014 7:40 pm

Hmmm... Looks weird.
Can I ask you to drop the StarWind logs on the moment of creation of the device by logging the support ticket using the form below:
http://www.starwindsoftware.com/support-form
Please put the reference to this thread to the message.

Thank you
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am

Re: Tape redirector setup issue

Postby jgrote » Thu Sep 25, 2014 11:18 pm

I have the same issue, with a Overland NEO changer.

[ URLs removed ]

Will deliver a log bundle.

Note presenting the individual tape drives works fine, but that's not terribly useful to me at this point, I need the library changer :)
jgrote
 
Posts: 2
Joined: Thu Sep 25, 2014 11:12 pm

Re: Tape redirector setup issue

Postby Anatoly (staff) » Fri Sep 26, 2014 8:55 am

Have you tried the workaround that I`ve suggested above?
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am

Re: Tape redirector setup issue

Postby jgrote » Fri Sep 26, 2014 2:40 pm

I tried the add to target method but the dialogs are the exact same. I didn't get the same error as the other poster, I select the tape library, then it asks for the tape drives with a blank dialog. If I add both tape drives first the same still happens. Perhaps I'm doing something incorrectly, more specific instructions perhaps?
jgrote
 
Posts: 2
Joined: Thu Sep 25, 2014 11:12 pm

Re: Tape redirector setup issue

Postby Anatoly (staff) » Mon Sep 29, 2014 8:54 am

Perrhaps you need to try out the SPTI feature of our main product -StarWind Virtual SAN. Can I ask you to test if it will work for you?
You can use free license for that.
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am


Return to StarWind Tape Redirector

Who is online

Users browsing this forum: No registered users and 0 guests