VSAN VM's (ESX) start in emergency mode!

Software-based VM-centric and flash-friendly VM storage + free version

Moderators: anton (staff), art (staff), Max (staff), Anatoly (staff)

Post Reply
Posts: 2
Joined: Wed Jun 12, 2024 5:13 pm

Wed Jun 12, 2024 5:41 pm

Hi there,

Been using the free VSAN VM's on two ESX8 hosts as a homelab for a couple of weeks now without any problems and actually running real stable and fast.

Until today when we had a power issue at home and both servers were cut off the power at the same time. After the power was back I powered on the ESX hosts again and I tried starting the first (primary?) VM. This one booted and ended with the following message on screen.
Welcome to emergency mode! After logging in, type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to try again to boot into default mode.
Not sure what to do now. The reboot and default option will start the VM back to the same screen. Also tried the other options in Grub. The second VM on the other host has the same issue.

The journalctl -xb option gives me a couple of red errors :
  • Failed to find modile 'bfq'
  • [sdc] No Caching mode page found (also for [sdb], but I think I saw this message when i WAS working aswell
  • [sdc] Assuming drive cache: write through (also for [sdb], but I think I saw this message when i WAS working aswell
  • Failed to start Load Kernel Modules
  • ip_local_port_range: prefer different parity for start/end values.
  • piix4_smbus 0000:00:07.3: SMBus Host Controller nog enabled!
  • Timed out waiting for device dev-disk-by\long_ID <<--- could this be the problem ?? I have nog issues with the disks
    The ID mentioned is missing, but also can't find it in /dev/disk/by-* in any directory.

    After a couple of lines it says it can't mount /mnt/disk2 <- An old disk I removed from the VM.

    I previously had 3 disks mounted (via RDM in ESX), but removed the one (the disk2). After that had no problem rebooting the VM so not sure if that's an issue.
Anyone have an idea how to fix this? Hope so, can't access my data now :shock:

And if fixing is a problem, or no one has an idea ... Maybe someone knows how I can access the data on the drives ?
Posts: 2
Joined: Wed Jun 12, 2024 5:13 pm

Wed Jun 12, 2024 5:51 pm

Uhmm ... feel so dumb right now. The mounting of disk 2 was actually still in the /etc/fstab file. I thought I had rebooted the VM's after removing disk 2, but apparently not.

After commenting out the line and rebooting, the VM's start without issues. And are now sychronizing.

yaroslav (staff)
Posts: 2531
Joined: Mon Nov 18, 2019 11:11 am

Wed Jun 12, 2024 6:26 pm

Glad to read you fixed it.
P.s. That's why I always add nofail mount option.
Post Reply