StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

HA_SYNCH_TYPE_FAST isn't available for current node

Pure software-based VM-centric and flash-friendly VM storage (iSCSI, SMB3, NFS, iSER and NVMe over Fabrics) including free version. Same software embedded on StarWind ready nodes.

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

HA_SYNCH_TYPE_FAST isn't available for current node

Postby gdibernardo » Wed Dec 18, 2019 3:03 pm

Hi,
I've downloaded and installed VSAN Free on two new 2019 Servers. I've created successfull the first HA Image & Target with CreateHA_2.ps1. The first sync was successfull and I can connect via iSCSI.
I've changed some params ($imageName and $size) in the CreateHA_2.ps1 and created the second HA Image. This was successful, but in the Mgmt Console ist on the 1st node an error: Partner "xxx" is not synchronized. In the logs there are the following warnings/errors:

Code: Select all
12/18 15:44:33.698510 8a8 HA: HANode::setIsNodeActive: Params(active = 1) ENTERed for target 'iqn.2008-08.com.starwindsoftware:hv2-hv2-ha'.
12/18 15:44:36.665746 20a8 HA: HANode::checkSyncTypeAvailableLocaly: Synchronization method <HA_SYNCH_TYPE_FAST> isn't available for current nodebecause cache mode is write back. The local node has not been shut gracefully and wasn't active.
12/18 15:44:36.667272 20a8 HA: HANode::synchronizeCurrentNode: Params(partnerNode = 0x00000169E712BD00, syncType = 1, snapshotId = 0x0, ignoreOwnSyncState = 0) ENTERed
12/18 15:44:36.667659 20a8 HA: HANode::synchronizeCurrentNode: Shutdown node before sending synchronization request!
12/18 15:44:36.667676 20a8 HA: HANode::shutdownCurrentNode_internal: Params(closeClientConnections = 1, sendShutdownNotifications = 1, partnerNodeNotificationExcluded = 0x0000000000000000, synchronizeCache = 1, synchronizeCacheSynchronously = 0, useHeaderCache = 0) ENTERed for target 'iqn.2008-08.com.starwindsoftware:hv2-hv2-ha'.
12/18 15:44:36.667789 20a8 HA: HANode::setIsNodeActive: Params(active = 0) ENTERed for target 'iqn.2008-08.com.starwindsoftware:hv2-hv2-ha'.
12/18 15:44:36.671303 20a8 HA: CHAPartnerNode::SendSynchronizationRequestCommand: ENTERed with params: p_SyncType = 1, p_ulSnapshotID = 0x0, p_bContinue = no, p_bVaaiWriteSame = yes
12/18 15:44:36.672374 259c HA: HANode::stopThreadSyncProgressPolling: Thread was not stopped, because thread isn't started.
12/18 15:44:36.672436 259c HA: HANode::setSyncStatus: Event: Device changed own sync status to 2 from 1. (target name = 'iqn.2008-08.com.starwindsoftware:hv2-hv2-ha')
12/18 15:44:36.676182 259c HA: HANode::runThreadSyncProgressPolling: Params(p_pPartnerNode = 0x00000169E70E29A0)
12/18 15:44:38.696844 1a68 HA: HANode::setSyncStatus: Event: Device changed own sync status to 1 from 2. (target name = 'iqn.2008-08.com.starwindsoftware:hv2-hv2-ha')
12/18 15:44:38.712976 1a68 PR: ResLunReservationEx::importState_CMD_V1: reservations imported.
12/18 15:44:38.713170 1a68 HA: HANode::setIsNodeActive: Params(active = 1) ENTERed for target 'iqn.2008-08.com.starwindsoftware:hv2-hv2-ha'.
12/18 15:44:41.670896 20a8 HA: HANode::checkSyncTypeAvailableLocaly: Synchronization method <HA_SYNCH_TYPE_FAST> isn't available for current nodebecause cache mode is write back. The local node has not been shut gracefully and wasn't active.
12/18 15:44:41.672445 20a8 HA: HANode::synchronizeCurrentNode: Params(partnerNode = 0x00000169E712BD00, syncType = 1, snapshotId = 0x0, ignoreOwnSyncState = 0) ENTERed
12/18 15:44:41.672832 20a8 HA: HANode::synchronizeCurrentNode: Shutdown node before sending synchronization request!
12/18 15:44:41.672849 20a8 HA: HANode::shutdownCurrentNode_internal: Params(closeClientConnections = 1, sendShutdownNotifications = 1, partnerNodeNotificationExcluded = 0x0000000000000000, synchronizeCache = 1, synchronizeCacheSynchronously = 0, useHeaderCache = 0) ENTERed for target 'iqn.2008-08.com.starwindsoftware:hv2-hv2-ha'.
12/18 15:44:41.672961 20a8 HA: HANode::setIsNodeActive: Params(active = 0) ENTERed for target 'iqn.2008-08.com.starwindsoftware:hv2-hv2-ha'.
12/18 15:44:41.677106 20a8 HA: CHAPartnerNode::SendSynchronizationRequestCommand: ENTERed with params: p_SyncType = 1, p_ulSnapshotID = 0x0, p_bContinue = no, p_bVaaiWriteSame = yes
12/18 15:44:41.678543 259c HA: HANode::stopThreadSyncProgressPolling: Thread was not stopped, because thread isn't started.
12/18 15:44:41.678609 259c HA: HANode::setSyncStatus: Event: Device changed own sync status to 2 from 1. (target name = 'iqn.2008-08.com.starwindsoftware:hv2-hv2-ha')
12/18 15:44:41.682231 259c HA: HANode::runThreadSyncProgressPolling: Params(p_pPartnerNode = 0x00000169E70E29A0)
12/18 15:44:43.702065 19f8 HA: HANode::setSyncStatus: Event: Device changed own sync status to 1 from 2. (target name = 'iqn.2008-08.com.starwindsoftware:hv2-hv2-ha')
12/18 15:44:43.717878 19f8 PR: ResLunReservationEx::importState_CMD_V1: reservations imported.


I don't understand why there is a difference between the creation of the first and the second Image. :shock:
why is the 1st one synced automatically and the second not? thank you very much!
gdibernardo
 
Posts: 2
Joined: Wed Dec 18, 2019 2:51 pm

Re: HA_SYNCH_TYPE_FAST isn't available for current node

Postby Boris (staff) » Sat Dec 21, 2019 4:57 am

We would need more logs in addition to the piece you have provided. Make sure to collect the log bundles from both HA partner nodes using StarWind Log Collector and send me a link to download them via private messages.
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: HA_SYNCH_TYPE_FAST isn't available for current node

Postby Boris (staff) » Thu Jan 09, 2020 2:46 pm

Unfortunately, the logs were submitted too late and the part we were interested in had gone because of log rotation.
One more issue seen in your environment is constant resync of StarWind disks. It happens every 3 seconds. To avoid any similar situation, make sure to adjust the following settings:
1. iSCSI link is suggested to have subnet mask 24, e.g. 172.16.10.1 and 172.16.10.2 (similar to what we indicate in our documentation.
2. Same is valid for Sync (VSAN) link. Make sure to adjust it, too. 172.16.20.1 and 172.16.20.2 will be a great choice for the IPs used for that interface on the two nodes. Again, subnet mask 24 is your preferred one (255.255.255.0) instead of the one you currently use.
Moreover, the system logs on both nodes have the network settings service started and stopped once or twice an hour, 3 minutes between the start and the stop events. This does not seem to be its proper behavior either. Make sure to check why it behaves like that to ensure proper operation of StarWind VSAN, as it is highly dependent on your networking configuration and operation.
Let me know if you have any additional questions.
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: HA_SYNCH_TYPE_FAST isn't available for current node

Postby gdibernardo » Mon Feb 10, 2020 12:57 pm

Hi,

I've written with boris via PM, but now he isn't longer employed with StarWind, so his forum account is now inactive. The last reply was that "about every hour your network settings service (Dienst "Netzwerkeinrichtungsdienst") starts and then stops - and this basically happens on both servers"
I've now installed both servers complety new, and installed Starwind vSAN on last Friday. I've used CreateHA_2.ps1 to craeate two Images. The first one (1GB) synced in less than a minute. The second one (5TB) won't start to sync. The Gui shows syncing... (0%) all the time. Last night we had a poweroutage. In the morning I booted both servers and tried to sync both (empty) images with the SyncHaDeviceAdvanced.ps1. The first image is in sync now the second Image not. The powershell console shows:

Device not synchronized. Synchronize current node from partner 'iqn.2008-08.com.starwindsoftware:svhv2-hv2-ha' but nothing happens. :roll:

I've installed the latest network drivers and uploaded the logs. I'll send the link via pm.

Thanks a lot! 8)
gdibernardo
 
Posts: 2
Joined: Wed Dec 18, 2019 2:51 pm

Re: HA_SYNCH_TYPE_FAST isn't available for current node

Postby Michael (staff) » Fri Feb 14, 2020 8:45 am

Hi gdibernardo,
Please share the logs, thus we could check them.
Michael (staff)
Staff
 
Posts: 285
Joined: Thu Jul 21, 2016 10:16 am


Return to StarWind Virtual SAN / StarWind Virtual SAN Free / StarWind HyperConverged Appliance / StarWind Storage Appliance

Who is online

Users browsing this forum: Google [Bot] and 2 guests