StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Problems installing Free version with ESX

Pure software-based VM-centric and flash-friendly VM storage (iSCSI, SMB3, NFS, iSER and NVMe over Fabrics) including free version. Same software embedded on StarWind ready nodes.

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Problems installing Free version with ESX

Postby jep » Fri Feb 22, 2019 1:51 pm

Trying to install the free version of VSAN as a proof of concept for possibly using at our company to replace using shared storage array between two hosts. Trying to follow the docs but not sure what I'm still missing.

I have my two StarWinds esx appliances up, with ip addresses, and local storage configured. I also have a management console running on a Windows VM. When I run the management console, I have the appliances connected, but I'm not able to add any devices. It's all greyed out. I know I haven't provided a lot of information here, but any clues on where to look?

Also, one more question. We use HA on our two ESX hosts. When you are using HA, you can't set specific VMs to startup and shutdown with the ESX host, so how exactly do you get these to start up?

Lastly, once the appliances are up and running, do they run independently of the StarWinds manager software?

Thanks
James
jep
 
Posts: 2
Joined: Thu Feb 21, 2019 6:49 pm

Re: Problems installing Free version with ESX

Postby Oleg(staff) » Mon Feb 25, 2019 11:05 am

Hi Jep,
I have my two StarWinds esx appliances up, with ip addresses, and local storage configured. I also have a management console running on a Windows VM. When I run the management console, I have the appliances connected, but I'm not able to add any devices. It's all greyed out. I know I haven't provided a lot of information here, but any clues on where to look?

StarWind Free version has Management Console only for monitoring, the options of creation/managing via console are available in trial and paid version. You can use and modify samples from StarWindX library from folder "C:\Program Files\StarWind Software\StarWind\StarWindX\Samples\powershell" according to your needs.

Also, one more question. We use HA on our two ESX hosts. When you are using HA, you can't set specific VMs to startup and shutdown with the ESX host, so how exactly do you get these to start up?

You can configure VMs startup/shutdown before enabling the vSphere HA option.

Lastly, once the appliances are up and running, do they run independently of the StarWinds manager software?

Yes, they can.
Oleg(staff)
Staff
 
Posts: 567
Joined: Fri Nov 24, 2017 7:52 am

Re: Problems installing Free version with ESX

Postby jep » Tue Feb 26, 2019 8:05 pm

Hello. I appreciate the response. I'm trying to use the CreateHA(two nodes) script. I keep getting this error:
Exception calling "CreateDevice" with "4" argument(s): "Failed to query volume properties: -1044527128
-
QueryVolumeProperties "/mnt/disk1"
-
104 Volume name required.. "

I can successfully run CreateImageFile and subsequently enumDevices just fine.

I cannot find any info on this error.

My script looks like this:
Code: Select all
Import-Module StarWindX

try
{
   Enable-SWXLog

   $server = New-SWServer -host 192.168.1.55 -port 3261 -user root -password starwind

   $server.Connect()

   $firstNode = new-Object Node

   $firstNode.HostName = "192.168.1.55"
   $firstNode.ImagePath = "/mnt/disk1"
   $firstNode.ImageName = "img1"
   $firstNode.Size = 1300234
   $firstNode.CreateImage = $true
   $firstNode.TargetAlias = "partnerHA1"
   $firstNode.AutoSynch = $true
   $firstNode.SyncInterface = "#p2=192.168.99.56:3260"
   $firstNode.HBInterface = "#p2=192.168.100.56:3260"
   $firstNode.PoolName = ""
   $firstNode.SyncSessionCount = 1
   $firstNode.ALUAOptimized = $true
   
   #
   # device sector size. Possible values: 512 or 4096(May be incompatible with some clients!) bytes.
   #
   $firstNode.SectorSize = 512
   
   $secondNode = new-Object Node

   $secondNode.HostName = "192.168.1.56"
   $secondNode.HostPort = "3261"
   $secondNode.Login = "root"
   $secondNode.Password = "starwind"
   $secondNode.ImagePath = "/mnt/disk1"
   $secondNode.ImageName = "img2"
   $secondNode.Size = 1300234
   $secondNode.CreateImage = $true
   $secondNode.TargetAlias = "partnerHA2"
   $secondNode.AutoSynch = $true
   $secondNode.SyncInterface = "#p1=192.168.99.55:3260"
   $secondNode.HBInterface = "#p1=192.168.100.55:3260"
   $secondNode.SyncSessionCount = 1
   $secondNode.ALUAOptimized = $true
       
   $device = Add-HADevice -server $server -firstNode $firstNode -secondNode $secondNode -initMethod "Clear"
   
   while ($device.SyncStatus -ne [SwHaSyncStatus]::SW_HA_SYNC_STATUS_SYNC)
   {
      $syncPercent = $device.GetPropertyValue("ha_synch_percent")
           Write-Host "Synchronizing: $($syncPercent)%" -foreground yellow

      Start-Sleep -m 2000

      $device.Refresh()
   }
}
catch
{
   Write-Host $_ -foreground red
}
finally
{
   $server.Disconnect()
}


Any help is appreciated.

Thanks.
jep
 
Posts: 2
Joined: Thu Feb 21, 2019 6:49 pm

Re: Problems installing Free version with ESX

Postby Oleg(staff) » Wed Feb 27, 2019 4:56 pm

Could you please log a support case using this form?
Please refer to this thread.
Oleg(staff)
Staff
 
Posts: 567
Joined: Fri Nov 24, 2017 7:52 am


Return to StarWind Virtual SAN / StarWind Virtual SAN Free / StarWind HyperConverged Appliance / StarWind Storage Appliance

Who is online

Users browsing this forum: Google [Bot] and 6 guests