StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
Request a Quote
Feel free to contact us:
USA and LATAM:
1-617-449-7717
EMEA and APAC:
+44(0)2071936727
+44(0)2071936350
+33(0)977197857 (French)
+49-1715109103 (Germany)
Voice Mail:
1-866-790-2646
Email:
sales@starwindsoftware.com
 
 

Unable to create new Hyper-V VM after successful vsan setup

Pure software-based VM-centric and flash-friendly VM storage (iSCSI, SMB3, NFS, iSER and NVMe over Fabrics) including free version. Same software embedded on StarWind ready nodes.

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Unable to create new Hyper-V VM after successful vsan setup

Postby jhemphi » Thu Mar 14, 2019 3:09 pm

I have a new 2 node hyperconverged StarWind Virtual SAN setup that I am trying to get running. All initial setup steps, HA Device creation and sync, Failover cluster test and creation, SOFS creation, Disk creation, initialization, partition/format, and folder/share creation all completed without error. However, every time I try to create a new VM, it fails with permission errors. Can't seem to figure out where I have gone wrong.
Any help would be greatly appreciated.
Thanks,
jhemphi
 
Posts: 3
Joined: Sat Feb 09, 2019 7:37 pm

Re: Unable to create new Hyper-V VM after successful vsan setup

Postby Boris (staff) » Thu Mar 14, 2019 4:51 pm

What privileges have you got in the environment? What type of account do you use? Can you reproduce the steps?
Boris (staff)
Staff
 
Posts: 547
Joined: Fri Jul 28, 2017 8:18 am

Re: Unable to create new Hyper-V VM after successful vsan setup

Postby jhemphi » Thu Mar 14, 2019 6:17 pm

Thanks for your reply.
I am a system administrator on the domain and I am using an account with full administrator privileges (member of both 'domain admins' and 'enterprise admins') however I am not using the actual "administrator" account.
I am using the VSan Free and StarwindX library with Powershell for administration of Starwind and a separate Win 10 Pro machine that is domain joined for other administration. Hyper-V servers are Server 2016 Core.
jhemphi
 
Posts: 3
Joined: Sat Feb 09, 2019 7:37 pm

Re: Unable to create new Hyper-V VM after successful vsan setup

Postby Boris (staff) » Thu Mar 14, 2019 7:16 pm

Any information on the steps you make to reproduce this permission issue?
Boris (staff)
Staff
 
Posts: 547
Joined: Fri Jul 28, 2017 8:18 am

Re: Unable to create new Hyper-V VM after successful vsan setup

Postby jhemphi » Thu Mar 14, 2019 11:59 pm

I used the guide "Hyperconverged 2-Node Scenario with Hyper-V Server 2016". Where the guide starts with Starwind Management Console, I used Powershell commands and the guidance from the samples in CreateHA(two nodes).ps1.
jhemphi
 
Posts: 3
Joined: Sat Feb 09, 2019 7:37 pm

Re: Unable to create new Hyper-V VM after successful vsan setup

Postby Boris (staff) » Fri Mar 15, 2019 1:05 am

I am generally interested in the Hyper-V part, as you've got the StarWind part of the environment up and running just fine.
In what way do you create VMs? What are the steps that you follow? This is the information I initially meant to request.
Boris (staff)
Staff
 
Posts: 547
Joined: Fri Jul 28, 2017 8:18 am


Return to StarWind Virtual SAN / StarWind Virtual SAN Free / StarWind HyperConverged Appliance / StarWind Storage Appliance

Who is online

Users browsing this forum: No registered users and 3 guests