StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Performance issue with StarPort AOE on W2K3

Initiator (iSCSI, FCoE, AoE, iSER and NVMe over Fabrics)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Performance issue with StarPort AOE on W2K3

Postby cmsmit » Tue Aug 29, 2006 2:01 pm

Hi,

Our customer has a Windows 2003 server with a SR420 attached to it. We loaded starport (v3.0.4) on it and installed the device, no problems there. Now when we copy data onto it the performance is around 4,5MB/s in stead of the ~60 MB/s that could be reached. The event log shows this event several times:

EventID 119
Source: Disk
Type: Error
The driver for device \Device\Harddisk3\DR9 delayed non-paging Io requests for 62 ms to recover from a low memory condition.

Has anyone experienced this behavior? What can we do about this?

Any help would be very much appreciated.

Thanks in advance,
Caspar
cmsmit
 
Posts: 6
Joined: Tue Aug 29, 2006 1:50 pm

Postby cmsmit » Tue Aug 29, 2006 2:44 pm

Btw,

These are the server specs:

Processor: Intel Celeron 2.4 GHz.
Mem: 512 MB of RAM
OS: Windows Server 2003 Standard Edition
SP: None
cmsmit
 
Posts: 6
Joined: Tue Aug 29, 2006 1:50 pm

Postby Val (staff) » Tue Aug 29, 2006 3:32 pm

cmsmit wrote:Btw,

These are the server specs:

Processor: Intel Celeron 2.4 GHz.
Mem: 512 MB of RAM
OS: Windows Server 2003 Standard Edition
SP: None

Hi,

I'd suggest you to install SP1 to the system.
StarPort officially supports Windows 2003 Server with SP1.
Best regards,
Valeriy
Val (staff)
 
Posts: 499
Joined: Tue Jun 29, 2004 8:38 pm

Postby cmsmit » Wed Sep 27, 2006 8:05 am

Ok we managed to install SP1 and everything works now without errors.

BUT the performance is still way from optimal, we get around 20-26 MB/s

I got the latest NIC drivers For my Intel Pro 1000 XT adapters.

The link speed is: 1GB/FULL DUPLEX

I tried without and with jumbo frames but to no result (btw, does the starport driver support jumbo frames)?

The CPU is ~50% when copying.

What can we do to get the ~60MB (without jumbo frames) or the promised 90-110 (with jumbo frames)?
cmsmit
 
Posts: 6
Joined: Tue Aug 29, 2006 1:50 pm

Postby anton (staff) » Wed Sep 27, 2006 12:32 pm

What's the attachment of the NIC? I mean bus type? Do you have any machine with PCI-X/PCIe NICs around? Can you install MS iSCSI initiator and use the same pair of machines to play with iSCSI? If the result would be the same - you'll have to swap the hardware.

cmsmit wrote:Ok we managed to install SP1 and everything works now without errors.

BUT the performance is still way from optimal, we get around 20-26 MB/s

I got the latest NIC drivers For my Intel Pro 1000 XT adapters.

The link speed is: 1GB/FULL DUPLEX

I tried without and with jumbo frames but to no result (btw, does the starport driver support jumbo frames)?

The CPU is ~50% when copying.

What can we do to get the ~60MB (without jumbo frames) or the promised 90-110 (with jumbo frames)?
Regards,
Anton Kolomyeytsev

Chief Technology Officer & Chief Architect, StarWind Software

Image
User avatar
anton (staff)
Site Admin
 
Posts: 3922
Joined: Fri Jun 18, 2004 12:03 am
Location: British Virgin Islands

Postby Val (staff) » Wed Sep 27, 2006 1:14 pm

cmsmit wrote:Ok we managed to install SP1 and everything works now without errors.

BUT the performance is still way from optimal, we get around 20-26 MB/s

I got the latest NIC drivers For my Intel Pro 1000 XT adapters.

The link speed is: 1GB/FULL DUPLEX

I tried without and with jumbo frames but to no result (btw, does the starport driver support jumbo frames)?

The CPU is ~50% when copying.

What can we do to get the ~60MB (without jumbo frames) or the promised 90-110 (with jumbo frames)?

Hi,

Do you use the recent firmware version for the Coraid device (20060907)?
We've recently found that StarPort versions older 3.0.8 RC do not understand the maximum sector count per transfer reported by the firmware, so ever with Jumbo frames enabled, these StarPort versions use only 2 sectors per request that lead to the same poor performance as with normal Ethernet 1500 bytes per frame.

We have fixed the issue. The new StarPort version is in our test labs and will be available for download in 2-3 days.

According to the mentioned maximum througput values (60 and 90-110 MB\s). FYI these values are rechable with a syntetic storage tests (like IOmeter, etc), while real filesystems and disk workloads tend to show 10-20MB/s less than IOMeter does.
Best regards,
Valeriy
Val (staff)
 
Posts: 499
Joined: Tue Jun 29, 2004 8:38 pm

Postby cmsmit » Wed Sep 27, 2006 2:09 pm

Thanks,

We will update the coraid to firmware 20060907 and wait for the new starport 3.0.8 version.

Bye,
Caspar
cmsmit
 
Posts: 6
Joined: Tue Aug 29, 2006 1:50 pm

Postby anton (staff) » Wed Sep 27, 2006 2:23 pm

You'd better still run iSCSI-related tests. At least you'd know physical throughoutput your machine is capable of.

cmsmit wrote:Thanks,

We will update the coraid to firmware 20060907 and wait for the new starport 3.0.8 version.

Bye,
Caspar
Regards,
Anton Kolomyeytsev

Chief Technology Officer & Chief Architect, StarWind Software

Image
User avatar
anton (staff)
Site Admin
 
Posts: 3922
Joined: Fri Jun 18, 2004 12:03 am
Location: British Virgin Islands

Postby cmsmit » Thu Oct 05, 2006 6:37 am

Hi,

Any news on the 3.0.8 version? It's been more then 2-3 days now.
cmsmit
 
Posts: 6
Joined: Tue Aug 29, 2006 1:50 pm

Postby Val (staff) » Thu Oct 05, 2006 8:23 am

cmsmit wrote:Hi,

Any news on the 3.0.8 version? It's been more then 2-3 days now.

Hi,
I've answered to you by email.
Please try the recent StarPort 3.0.8 RC version.
Best regards,
Valeriy
Val (staff)
 
Posts: 499
Joined: Tue Jun 29, 2004 8:38 pm

Postby Yacine » Wed Oct 18, 2006 12:10 pm

Hi,

Where to find 3.0.8 final or RC1 ???

Cause I have downloaded the evaluation version yesterday and it is 3.0.4 Build 0x20060620 !

Thank you.
Yacine
 
Posts: 21
Joined: Tue May 09, 2006 1:09 pm

Postby Val (staff) » Wed Oct 18, 2006 12:26 pm

Yacine wrote:Hi,

Where to find 3.0.8 final or RC1 ???

Cause I have downloaded the evaluation version yesterday and it is 3.0.4 Build 0x20060620 !

Thank you.

Check your email please.
Best regards,
Valeriy
Val (staff)
 
Posts: 499
Joined: Tue Jun 29, 2004 8:38 pm


Return to StarPort

Who is online

Users browsing this forum: No registered users and 1 guest