StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Device access is denied,pls help!

Initiator (iSCSI, FCoE, AoE, iSER and NVMe over Fabrics)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Device access is denied,pls help!

Postby k-fei » Tue Jul 18, 2006 2:09 am

when i choose Remote iSCSI devices,click "next" show error:


OS:Win XP SP2
StarPort 3.0 build 0x20060322

pls help me ,thank you!!!
k-fei
 
Posts: 4
Joined: Tue Jul 18, 2006 1:58 am

Re: Device access is denied,pls help!

Postby Val (staff) » Tue Jul 18, 2006 10:36 pm

k-fei wrote:when i choose Remote iSCSI devices,click "next" show error:
"Device access is denied"

OS:Win XP SP2
StarPort 3.0 build 0x20060322

pls help me ,thank you!!!

hi,
This is an unusual error message for StarPort.
Please send us your StarPort.log file.
Best regards,
Valeriy
Val (staff)
 
Posts: 499
Joined: Tue Jun 29, 2004 8:38 pm

Postby k-fei » Wed Jul 19, 2006 4:18 am

hi,this is my StarPort.log,thank you!!!

04:02:58 - Entering func: CLanguager::LoadLanguage(language=0x409)
04:02:58 - Exiting func: CLanguager::LoadLanguage(language=0x409)
04:02:58 - CStarPortApp::CheckLicense: Licensed to: 'kfei', 'nGen', (#0, 268435455), 'ram iscsi dvd aoe', #268435455 .
04:02:58 - CStarPortApp::CheckLicense: *** LICENSE is VALID ***
04:02:58 - CStarPortApp::CheckLicense: *** SITE LICENSE is VALID ***
04:02:58 - Entering func: CStarPortAPI::CStarPortAPI()
04:02:58 - Entering func: CStarPortAPI::DriverOpen()
04:02:58 - Exiting func: CStarPortAPI::DriverOpen()
04:02:58 - Entering func: CStarPortAPI::DriverVersion(...)
04:02:58 - CStarPortAPI::DriverVersion: Calling STARPORT_IOCTL_GET_VERSION
04:02:58 - CStarPortAPI::DriverVersion: Calling DeviceIoControl(...)
04:02:58 - CStarPortAPI::DriverVersion: Input: ApiVersion = 30000
04:02:58 - CStarPortAPI::DriverVersion: Output: Version = 20060322, API = 30000, Flags = 0
04:02:58 - Exiting func: CStarPortAPI::DriverVersion(...)
04:02:58 - CStarPortAPI::CStarPortAPI: StarPort version: 20060320; StarPort driver: API v30000, Build 0x20060322
04:02:58 - Exiting func: CStarPortAPI::CStarPortAPI()
04:02:58 - Entering func: CDriveLetterMap::CDriveLetterMap()
04:02:58 - Entering func: CDriveLetterMap::Refresh()
04:02:58 - Exiting func: CDriveLetterMap::Refresh()
04:02:58 - Exiting func: CDriveLetterMap::CDriveLetterMap()
04:02:58 - Entering func: CStarPortDoc::CStarPortDoc()
04:02:58 - Exiting func: CStarPortDoc::CStarPortDoc()
04:02:58 - CMainFrame::OnCreate: Minimizing application to tray.
04:02:58 - Entering func: CStarPortAPI::GetEthernetAdapters()
04:02:58 - CStarPortAPI::GetEthernetAdapters: Adapter=\DEVICE\{A4EB55A9-BFBA-4393-8A7D-4006EE516AEA}
04:02:58 - CStarPortAPI::GetEthernetAdapters: MAC=00:50:8D:ED:B7:3C
04:02:58 - CStarPortAPI::GetEthernetAdapters: Name=VIA Networking Velocity Family Giga-bit Ethernet Adapter
04:02:58 - Exiting func: CStarPortAPI::GetEthernetAdapters()
04:02:58 - Entering func: CStarPortView::OnInitialUpdate()
04:02:58 - Entering func: CStarPortDoc::ResyncRegistryAndDriverContents(bAutomountDevices=1)
04:02:58 - Entering func: CDriveLetterMap::Refresh()
04:02:58 - Exiting func: CDriveLetterMap::Refresh()
04:02:58 - Entering func: CStarPortAPI::GetDevices(...)
04:02:58 - CStarPortAPI::GetDevices: Calling STARPORT_IOCTL_TARGET_LIST
04:02:58 - CStarPortAPI::GetDevices: Output buffer:
04:02:58 - CStarPortAPI::GetDevices: NumberOfTargets = 0
04:02:58 - Exiting func: CStarPortAPI::GetDevices(...)
04:02:58 - Exiting func: CStarPortDoc::ResyncRegistryAndDriverContents(bAutomountDevices=1)
04:02:58 - Exiting func: CStarPortView::OnInitialUpdate()
04:03:02 - CMainFrame::OnTrayStartManagement: Maximizing from tray.
04:03:06 - Entering func: CStarPortView::OnRButtonDown(...)
04:03:06 - CStarPortView::OnRButtonDown: Calling OnContextMenu.
04:03:06 - Entering func: CStarPortView::OnContextMenu(...)
04:03:07 - Exiting func: CStarPortView::OnContextMenu(...)
04:03:07 - Exiting func: CStarPortView::OnRButtonDown(...)
04:03:10 - Entering func: CStarPortAPI::GetTargets(dwIPAddress=0xC0A80166, DWORD dwPort=3260, listTargets=...)
04:03:10 - CStarPortAPI::GetTargets: Calling STARPORT_IOCTL_GET_TARGETS
04:03:10 - CStarPortAPI::GetTargets: Input buffer:
04:03:10 - CStarPortAPI::GetTargets: ServerAddress = 192.168.1.102:3260
04:03:10 - CStarPortAPI::GetTargets: Parameter[0] = InitiatorName=iqn.1991-05.com.microsoft:mashimaro
04:03:10 - CStarPortAPI::GetTargets: Session failed, status == 5 !
04:03:10 - Exiting func: CStarPortAPI::GetTargets(dwIPAddress=0xC0A80166, DWORD dwPort=3260, listTargets=...)
04:03:10 - CWPPiSCSIDeviceCreate::GetTargetsList: Exception caught: Device access is denied.
k-fei
 
Posts: 4
Joined: Tue Jul 18, 2006 1:58 am

Postby Val (staff) » Wed Jul 19, 2006 8:59 am

Thank you for the log.
Please try to upgrade to the recent StarPort 3.0.4.

Do you use any personal firewalls on the initiator machine?

Have you tried the MS iSCSI initiator to connect the same iSCSI target?
Best regards,
Valeriy
Val (staff)
 
Posts: 499
Joined: Tue Jun 29, 2004 8:38 pm

Postby k-fei » Wed Jul 19, 2006 11:02 am

i already open 3260 port,and tried MS iSCSI initiator to connect the same iSCSI target,show error "target error"
i can't connect local pc too,and the other pc connect this pc is no problem.
i don't know what's wrong,os have not any abnormal
k-fei
 
Posts: 4
Joined: Tue Jul 18, 2006 1:58 am

Postby Val (staff) » Wed Jul 19, 2006 11:08 am

k-fei wrote:i already open 3260 port,and tried MS iSCSI initiator to connect the same iSCSI target,show error "target error"
i can't connect local pc too,and the other pc connect this pc is no problem.
i don't know what's wrong,os have not any abnormal

As the MS initiator can't connect to the target too, I suspect there is something wrong with the machine.
Please recheck your personal firewall rules or network settings.
Best regards,
Valeriy
Val (staff)
 
Posts: 499
Joined: Tue Jun 29, 2004 8:38 pm

Postby anton (staff) » Wed Jul 19, 2006 12:52 pm

Posting a list of installed software may help. FYI.
Regards,
Anton Kolomyeytsev

Chief Technology Officer & Chief Architect, StarWind Software

Image
User avatar
anton (staff)
Site Admin
 
Posts: 3922
Joined: Fri Jun 18, 2004 12:03 am
Location: British Virgin Islands

Postby k-fei » Wed Jul 19, 2006 5:47 pm

my software list,please


and i will check my pc,thanks for yours help
k-fei
 
Posts: 4
Joined: Tue Jul 18, 2006 1:58 am

Postby anton (staff) » Thu Jul 20, 2006 11:26 am

No suspected broken firewall software, sorry :( Please double check your network settings. If other machines can connect to iSCSI target - your personal machine (initiator) is guilty in some way (as both StarPort and MS initiator fail to work). But we've never seen such a thing before and we'd really appreciate if you'd let us know what it was. Thanks!
Regards,
Anton Kolomyeytsev

Chief Technology Officer & Chief Architect, StarWind Software

Image
User avatar
anton (staff)
Site Admin
 
Posts: 3922
Joined: Fri Jun 18, 2004 12:03 am
Location: British Virgin Islands


Return to StarPort

Who is online

Users browsing this forum: No registered users and 1 guest