StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

StarWind initiator hangs when I try remote iscsi

Initiator (iSCSI, FCoE, AoE, iSER and NVMe over Fabrics), iSCSI accelerator and RAM disk

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

StarWind initiator hangs when I try remote iscsi

Postby win7iscsi » Thu Jun 27, 2013 1:03 am

I have just install the StarWInd iSCSI Iniator.

Whenever I launch it and try to add to a remote target the product hangs and there is no way to kill it.

The windows task manager Applications pane shows: "StarWind iSCSI Initiator" not responding
The windows task manager Processes pane shows: "StarISCSI.exe *32"

I tried to end process, process tree but nothing works.

I first ran with Microsoft default iSCSI initiator still runing but I've since removed that, disabled the Microsoft iSCSI initiator Service and the Microsoft iSCSI Device. I've rebooted between tests and it doesn't matter what I do. The StarWind initiator just hangs every time I run it.

The log file is full of thousands and thousands of lines like:

6/26 18:09:56.265 CMainFrame::PoolingServiceEvents: Event checking failed, status == 2
6/26 18:09:56.671 >> CMainFrame::CheckForEventMessage()
6/26 18:09:56.671 CMainFrame::PoolingServiceEvents: Event checking failed, status == 2
6/26 18:09:57.077 >> CMainFrame::CheckForEventMessage()
6/26 18:09:57.077 CMainFrame::PoolingServiceEvents: Event checking failed, status == 2

I really want to use this initiator as I believe the Microsoft one keeps bluescreen crashing my PC when I use BusTrace application.

If this StarWind initiator is not supported any longer or is known defective just let me know.

Thank you.

-Tim
win7iscsi
 
Posts: 1
Joined: Thu Jun 27, 2013 12:53 am

Re: StarWind initiator hangs when I try remote iscsi

Postby anton (staff) » Thu Jun 27, 2013 9:35 am

1) Try checking your firewall settings. Looks like the port is closed. Also logs from the target side should be handy.

2) StarPort is a discontinued product. So you'll have to stick with BSOD-ing Microsoft one for production.

P.S. And make sure turning OFF all the filter drivers you use. Just to see StarPort working
Regards,
Anton Kolomyeytsev

Chief Technology Officer & Chief Architect, StarWind Software

Image
User avatar
anton (staff)
Site Admin
 
Posts: 3935
Joined: Fri Jun 18, 2004 12:03 am
Location: British Virgin Islands


Return to StarWind NVMe-oF Initiator, StarWind iSCSI Accelerator, StarWind RAM Disk

Who is online

Users browsing this forum: No registered users and 1 guest