StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Install using DrvInst.exe

Initiator (iSCSI, FCoE, AoE, iSER and NVMe over Fabrics)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Install using DrvInst.exe

Postby jagsrikal » Mon Dec 10, 2012 12:37 pm

I downloaded the ISCSI initator from this link
http://www.starwindsoftware.com/custome ... rSetup.exe

When i Try to do Drvinst.exe -install root/stariscsi
D:\openoffice\iSCSI Initiator>DrvInst.exe -install [root\stariscsi] "D:\openoffi
ce\iSCSI Initiator\iscsi.reg"

DrvInstDriverInstallOrUpdate failed (3758096640) !

What could be the issue that it does not work on cmd line but works while using exe directly

Thanks
Vidya
jagsrikal
 
Posts: 4
Joined: Mon Dec 10, 2012 12:26 pm

Re: Install using DrvInst.exe

Postby Anatoly (staff) » Mon Dec 10, 2012 2:53 pm

Just doublechecking - can you confirm that you are installing it on Windows OS?
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am

Re: Install using DrvInst.exe

Postby jagsrikal » Tue Dec 11, 2012 5:38 am

I am trying this on a windows xp machine
jagsrikal
 
Posts: 4
Joined: Mon Dec 10, 2012 12:26 pm

Re: Install using DrvInst.exe

Postby anton (staff) » Tue Dec 11, 2012 11:20 pm

What exactly are you trying to do? What's the reason of setup-less installation?
Regards,
Anton Kolomyeytsev

Chief Technology Officer & Chief Architect, StarWind Software

Image
User avatar
anton (staff)
Site Admin
 
Posts: 3920
Joined: Fri Jun 18, 2004 12:03 am
Location: British Virgin Islands

Re: Install using DrvInst.exe

Postby jagsrikal » Wed Dec 12, 2012 6:28 am

I would like to have the the iscsi initator on Bart PE/winpe. So i tried to copy the folder to bartpe. I exported the reg entries from regedit.
I used pluginbuilder to install the iscsi.sys file in system32/drivers
However iscsi does not run and says driver not installed.

When i tried to port mono to run .net app in winpe/bartpe, I just need to copy the required mono folders from program files and reg entries and just run the exe from correct location. I was trying a similar method for starwind iscsi initator. However it does not seem to be direct.

Any pointers would be helpful.

Regards
Vidya
jagsrikal
 
Posts: 4
Joined: Mon Dec 10, 2012 12:26 pm

Re: Install using DrvInst.exe

Postby Val (staff) » Wed Dec 12, 2012 12:46 pm

jagsrikal wrote:When i Try to do Drvinst.exe -install root/stariscsi
D:\openoffice\iSCSI Initiator>DrvInst.exe -install [root\stariscsi] "D:\openoffi
ce\iSCSI Initiator\iscsi.reg"

DrvInstDriverInstallOrUpdate failed (3758096640) !

What could be the issue that it does not work on cmd line but works while using exe directly

Hi,

The command line is wrong.
Code: Select all
DrvInst.exe usage:
 Driver Install (only new installation):
        -install <DevId> <InfFileFullName>
        -installpnp <DevId> <InfFileFullName>
        -preinstall <InfFileFullName> <Driver files path>

 Driver Update:
        -update <DevId> <InfFileFullName>
        -updatepnp <DevId> <InfFileFullName>

 Driver Uninstall:
        -uninstall <DevId> <message>

 Check if Driver Installed:
        -check <DevId>

So you need something like the following to manually install the driver:
DrvInst.exe -install root\stariscsi <path_to_Starporti.inf_file>
Best regards,
Valeriy
Val (staff)
 
Posts: 499
Joined: Tue Jun 29, 2004 8:38 pm

Re: Install using DrvInst.exe

Postby lexter » Wed Mar 20, 2013 11:44 am

Val (staff) wrote:
jagsrikal wrote:When i Try to do Drvinst.exe -install root/stariscsi
D:\openoffice\iSCSI Initiator>DrvInst.exe -install [root\stariscsi] "D:\openoffi
ce\iSCSI Initiator\iscsi.reg"

DrvInstDriverInstallOrUpdate failed (3758096640) !

What could be the issue that it does not work on cmd line but works while using exe directly

Hi,

The command line is wrong.
Code: Select all
DrvInst.exe usage:
 Driver Install (only new installation):
        -install <DevId> <InfFileFullName>
        -installpnp <DevId> <InfFileFullName>
        -preinstall <InfFileFullName> <Driver files path>

 Driver Update:
        -update <DevId> <InfFileFullName>
        -updatepnp <DevId> <InfFileFullName>

 Driver Uninstall:
        -uninstall <DevId> <message>

 Check if Driver Installed:
        -check <DevId>

So you need something like the following to manually install the driver:
DrvInst.exe -install root\stariscsi <path_to_Starporti.inf_file>


It's working on cmd, I've tried this code and I think it's the best solution for your issue.
lexter
 
Posts: 1
Joined: Wed Mar 20, 2013 11:41 am

Re: Install using DrvInst.exe

Postby anton (staff) » Wed Mar 20, 2013 6:22 pm

Why do you need manual script-driven install?
Regards,
Anton Kolomyeytsev

Chief Technology Officer & Chief Architect, StarWind Software

Image
User avatar
anton (staff)
Site Admin
 
Posts: 3920
Joined: Fri Jun 18, 2004 12:03 am
Location: British Virgin Islands

Re: Install using DrvInst.exe

Postby jagsrikal » Wed May 15, 2013 5:36 pm

Sorry for delayed reply. I am trying to get winpe with iscsi. As mentioned before most s/w like mono ,msiscsi , i would just need to copy folder and make correct reg entries.
So is there any specifc procedure to port this to Winpe.
jagsrikal
 
Posts: 4
Joined: Mon Dec 10, 2012 12:26 pm

Re: Install using DrvInst.exe

Postby anton (staff) » Wed May 15, 2013 6:12 pm

Never looked @ this (PE install). Manual mode with DrvInst.exe should work however.

jagsrikal wrote:Sorry for delayed reply. I am trying to get winpe with iscsi. As mentioned before most s/w like mono ,msiscsi , i would just need to copy folder and make correct reg entries.
So is there any specifc procedure to port this to Winpe.
Regards,
Anton Kolomyeytsev

Chief Technology Officer & Chief Architect, StarWind Software

Image
User avatar
anton (staff)
Site Admin
 
Posts: 3920
Joined: Fri Jun 18, 2004 12:03 am
Location: British Virgin Islands


Return to StarPort

Who is online

Users browsing this forum: No registered users and 1 guest