StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

DPM 2012 R2 Server 2012 R2 Dell TL4000 Tape Library

Tape drive and auto-loader redirector (iSCSI)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

DPM 2012 R2 Server 2012 R2 Dell TL4000 Tape Library

Postby wschenk » Fri Dec 18, 2015 3:48 pm

I have a Hyper-V host running Server 2012 R2 that directly connects to the Dell TL4000 tape Library via a SAS HBA card. The Library has two tape drives, both of which show up in device manager on the host machine. I have updated drivers / firmware.

I would like to share via iSCSI the tape library to a Hyper-V Virtual Machine hosted on the above machine. The Virtual Machine also runs Server 2012 R2 and DPM 2012 R2.

I created a target that has both drives and a control device. I attached them on the VM via iSCSI Initiator and they show up both in Device manager and DPM. But they only show up as 1 tape, specifically the cleaning tape. I can not inventory the whole library. I tried adding the devices as a Tape drive/autoloader but they are not listed in Starwind mgmt console. Any ideas?
wschenk
 
Posts: 4
Joined: Fri Dec 18, 2015 3:14 pm

Re: DPM 2012 R2 Server 2012 R2 Dell TL4000 Tape Library

Postby Vladislav (Staff) » Wed Dec 23, 2015 12:40 pm

Hi wschenk,

Have you installed TL 4000 drivers inside the VM?
Vladislav (Staff)
Staff
 
Posts: 180
Joined: Fri Feb 27, 2015 4:31 pm

Re: DPM 2012 R2 Server 2012 R2 Dell TL4000 Tape Library

Postby wschenk » Mon Jan 04, 2016 4:35 pm

Yes I have installed drivers on both the host machine and the VM
wschenk
 
Posts: 4
Joined: Fri Dec 18, 2015 3:14 pm

Re: DPM 2012 R2 Server 2012 R2 Dell TL4000 Tape Library

Postby Anatoly (staff) » Mon Jan 04, 2016 11:22 pm

Could you please share the screenshots of hte device manager that would illustrate that the library driver is installed on both hosts?

thank you

P.S. Yea, I know that this is annoying, so please take my apologize, but we need to be completely sure.
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am

Re: DPM 2012 R2 Server 2012 R2 Dell TL4000 Tape Library

Postby wschenk » Wed Jan 06, 2016 2:55 pm

below are the two requested screenshots

Hostserver.PNG
Hostserver.PNG (29.44 KiB) Viewed 12021 times



DPMserver.PNG
DPMserver.PNG (28.05 KiB) Viewed 12021 times
wschenk
 
Posts: 4
Joined: Fri Dec 18, 2015 3:14 pm

Re: DPM 2012 R2 Server 2012 R2 Dell TL4000 Tape Library

Postby wschenk » Thu Jan 07, 2016 3:06 pm

We realized we had the SAS connectors routed wrong on the Library. Both cables were only in one drive, which was not the control path. fixed that and now seeing full library and able to send to VM.
wschenk
 
Posts: 4
Joined: Fri Dec 18, 2015 3:14 pm

Re: DPM 2012 R2 Server 2012 R2 Dell TL4000 Tape Library

Postby Vladislav (Staff) » Mon Jan 11, 2016 11:15 am

Hello!

Great to hear that your issue was solved.

Is there anything else we can assist you with? :)
Vladislav (Staff)
Staff
 
Posts: 180
Joined: Fri Feb 27, 2015 4:31 pm


Return to StarWind Tape Redirector

Who is online

Users browsing this forum: No registered users and 1 guest