StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Tape Redirector and Backup Exec issue: tape goes offline

Tape drive and auto-loader redirector (iSCSI)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Tape Redirector and Backup Exec issue: tape goes offline

Postby Anatoly (staff) » Thu Aug 14, 2014 6:23 pm

Gentlemen,
Our forum users and customers reported about the issue with StarWind and Backup Exec. We`ve made the research and find out where the problem is.
Symptoms:
The SAS tape that Backup Exec uses randomly goes offline.


Solution
Unfortunately there is no solution for this at the moment, since it looks like this is Symantec issue. Multiple users, regardless were they using StarWind or not, reported the similar problem to Backup Exec forum:
http://www.symantec.com/connect/forums/ ... ve-offline
http://www.symantec.com/connect/forums/ ... e-randomly
http://www.symantec.com/connect/forums/ ... es-offline
http://www.symantec.com/connect/forums/ ... middle-job
http://www.symantec.com/connect/forums/ ... ng-offiine
http://www.symantec.com/connect/forums/ ... ackup-exec

Our forum:
viewtopic.php?p=21837#p21837

And other communities:
http://www.rm.com/Support/TechnicalArti ... TEC3329004
http://community.spiceworks.com/topic/3 ... is-offline
Google is really responsive to that request

The issue is reproducing with all the BackupExec versions: 2010, 2012, 2014, and it is only affecting the SAS tapes, from what we can see.


The Conclusion that we made is that there is nothing to do with tape redirector, and this is BE issue, and so the best thing that can be done here is to contact their support or post to their forum, and hopefully one day this issue will be fixed.

Nevertheless you can try to do following to workaround the issue:
Create the PowerShell script file with the following content on the machine that is connected to the exported Tape:

Code: Select all
# cmdlet for bringing a tape drive back on-line. Uses BEMCLI (Backup Execs CLI). For use with BUE2012. 
Import-Module BEMCLI
Get-BETapeDriveDevice | Set-BETapeDriveDevice -Paused $False


As the next step basic task needs to be created. To achieve that please take following steps:
Select the Trigger- Select Event Viewer - (look in even viewer for an Event ID that occurs when the drive goes offline, i.e Application, Source: backup Exec, EventID: 58053
in Actions write in the program: powershell.exe
in the additional Parameters: -ExecutionPolicy unrestricted -file "C:\Program Files\Symantec\%PowerShell-file-name%"


How to help us to get to the bottom of the issue if you still have some doubts:
1) What tape library and SCSI/SAS controller do you use?
2) On StarWind (Tape Redirector) machine install and launch wireshark, set packet filter options ("tcp port 3260" if you are using StarWind v8 software, or "tcp port 33268"), start packet capturing, reproduce the issue with the tape, save wireshark log, zip and send us wireshark and BE (adamm.log) logs.
3) Make sure that your HBA card is supported for tape: http://www.symantec.com/connect/forums/ ... ve-offline

Thank you for your reading!
Last edited by art (staff) on Thu Apr 23, 2015 4:37 pm, edited 2 times in total.
Reason: 1
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am

Re: Tape Redirector and Backup Exec issue: tape goes offline

Postby Blue407 » Thu Apr 02, 2015 3:08 pm

To be clear, we need to do this on the host machine, the one with the tape drive physically connected?
Blue407
 
Posts: 28
Joined: Tue Jul 29, 2014 8:59 pm

Re: Tape Redirector and Backup Exec issue: tape goes offline

Postby Anatoly (staff) » Sun Apr 05, 2015 8:33 pm

Ecactly
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am

Re: Tape Redirector and Backup Exec issue: tape goes offline

Postby Blue407 » Mon Apr 06, 2015 9:34 am

Anatoly (staff) wrote:Ecactly


But backup exec isn't installed on that machine, so the library won't be installed.
Don't you mean to do this on the VM that backup exec is installed on?
Blue407
 
Posts: 28
Joined: Tue Jul 29, 2014 8:59 pm

Re: Tape Redirector and Backup Exec issue: tape goes offline

Postby Anatoly (staff) » Tue Apr 07, 2015 9:59 am

Pardon, I misunderstood your question. So, yeah, the script should be on the backup box.
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am


Return to StarWind Tape Redirector

Who is online

Users browsing this forum: No registered users and 1 guest