StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Starwind VTL Cloud Replication to Azure

StarWind VTL / VTL Appliance / Storage Gateway for Backblaze

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Starwind VTL Cloud Replication to Azure

Postby marciofeld » Sun Dec 09, 2018 1:19 am

Hello,
I've using Starwind VTL Free with Cloud Replication to Azure for the last three months. It has been uploading without problems.
Since last week, It is not uploading anything anymore. There are lot's of Virtual Tapes with the status "Uploading 0.0%", but it does not change.
I've already tried to run the Cloud Replication Setup again to insert the Access Key, but it did not change this behaviour.
Yesterday I made a test by downloading an Azure Archived Virtual Tape, and it worked perfectly.
Can someone help me???
marciofeld
 
Posts: 7
Joined: Wed Oct 24, 2018 4:01 pm

Re: Starwind VTL Cloud Replication to Azure

Postby marciofeld » Sun Dec 09, 2018 1:29 am

I forgot to mention that I also tried to restart the "Cloud Replication" Service and also reboot the Guest OS.
marciofeld
 
Posts: 7
Joined: Wed Oct 24, 2018 4:01 pm

Re: Starwind VTL Cloud Replication to Azure

Postby Boris (staff) » Sun Dec 09, 2018 7:42 am

Can you send us the logs related to CloudVTL? You can find them in the CloudVTL folder in the StarWind installation folder. Use your preferred service to upload them and provide the link via private messages.
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: Starwind VTL Cloud Replication to Azure

Postby marciofeld » Mon Dec 10, 2018 2:14 am

Hello Boris,
Thanks for your support!

I just sent you the link by private message.
I was unable to find any "CloudVTL" subfolder under the Starwind installation folder, but I found the "Cloud Replication" folder and sent it's logs.

Looking forward for your comments.
marciofeld
 
Posts: 7
Joined: Wed Oct 24, 2018 4:01 pm

Re: Starwind VTL Cloud Replication to Azure

Postby Boris (staff) » Mon Dec 10, 2018 5:04 pm

My memory served me wrong regarding the proper folder name. It's great you figured it out on your own.
I will check the logs and let you know the results.
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: Starwind VTL Cloud Replication to Azure

Postby Boris (staff) » Mon Dec 10, 2018 5:50 pm

marciofeld,

Based on your logs, the latest part of which was dated Dec 8, there is still one upload active:
Code: Select all
BlobName: SW8P2006.VTdat, Progress: 88.78

All the remaining tapes must be queued until this one is uploaded.
At this point the matter of your ISP's upload speed is the one that would interest you considerably.
Boris (staff)
Staff
 
Posts: 806
Joined: Fri Jul 28, 2017 8:18 am

Re: Starwind VTL Cloud Replication to Azure

Postby marciofeld » Mon Dec 10, 2018 7:29 pm

Thanks for your attention, Boris!
The tape "SW8P2006" was showing as "Upload 0.00%" last week, and it is going to expire on the current week, so I decided to push the button "Insert" to insert this tape from the Offline Shelf to the I/E Slots, and then send the command to Erase the tape from Veeam B&R to free up disk space.
When I tried to Erase this tape, I received a Tape Protection Error, but it is not upload anymore, as you can see in my Starwind VTL Console screenshot:

Image

Is there a way I can cancel this dummy upload?
marciofeld
 
Posts: 7
Joined: Wed Oct 24, 2018 4:01 pm

Re: Starwind VTL Cloud Replication to Azure

Postby marciofeld » Tue Dec 11, 2018 2:28 am

PROBLEM SOLVED!!!

I'd like to share with you how I solved this problem.

After Boris identify what tape was locking the uploads using the logs I sent to him, I exported the tape using Veeam. This tape was previously inserted (as mentioned on my previous messages), and when I exported it, the tape went back to the VTL Offline Shelf.
After that, the Starwind VTL showed up the upload percentage (something about 84%), but I waited for 10 minutes and nothing changed.
What I did was to Restart the "Cloud Replication" Service on my Windows Server and it continued uploading the tape!

Boris, thank you so much for your help!!!

Image
marciofeld
 
Posts: 7
Joined: Wed Oct 24, 2018 4:01 pm

Re: Starwind VTL Cloud Replication to Azure

Postby Oleg(staff) » Tue Dec 11, 2018 9:25 am

You are welcome!
Oleg(staff)
Staff
 
Posts: 564
Joined: Fri Nov 24, 2017 7:52 am


Return to StarWind VTL / VTL Appliance / Storage Gateway for Backblaze

Who is online

Users browsing this forum: No registered users and 1 guest