How to connect MPIO correct

Public beta (bugs, reports, suggestions, features and requests)

Moderators: anton (staff), art (staff), Max (staff), Anatoly (staff)

Post Reply
fanello
Posts: 19
Joined: Mon May 05, 2014 2:48 pm

Tue May 06, 2014 6:01 pm

Hi,

I'm not sure how to connect Starwind correct. I'm using a 2-node cluster. If I connect the way the manual tells me and just click connect and enable the Multipath Box, the connections listet under MPIO are not multiple. There are just my 2 Servers listet, but only the x.x.212.x interface and not the secound interface x.x.213.x.
If I connect like shown on the right side of the picture, I end up with 2 devices, each device connected to all 4 interfaces.
1gerät.png
1gerät.png (102.01 KiB) Viewed 13477 times
What is the correct way of connecting?

Thanks for your help.

Regards
Benny
User avatar
Bohdan (staff)
Staff
Posts: 435
Joined: Wed May 23, 2007 12:58 pm

Tue May 06, 2014 7:19 pm

Please make sure that

Code: Select all

<iScsiDiscoveryListInterfaces value="1"/>
option in your StarWind.cfg files is uncommented and set to 1.
In order to apply StarWind.cfg changes, restart StarWindService after editing.
fanello
Posts: 19
Joined: Mon May 05, 2014 2:48 pm

Wed May 07, 2014 2:56 pm

Hi,

thanks for reply. In order to connect my host with both iSCSI Interfaces x.x.212.x and x.x.213.x to my Starwind Cluster, which options do I have to set?
Are there any performance tweaks for 10 GbE Networks? I changed my Network to 10 GbE, speed increased, but starwind uses just about 30% of its potential. I'm using SSDs, so it probalby could go much faster.

regards
Benny
User avatar
Bohdan (staff)
Staff
Posts: 435
Joined: Wed May 23, 2007 12:58 pm

Wed May 07, 2014 6:48 pm

You should connect it twice:
1) specifying initiator and target IP addresses from the x.x.212.x subnet
2) specifying initiator and target IP addresses from the x.x.213.x subnet

also make sure that you have Windows Mutipath functionality enabled for iSCSI devices.
Post Reply