StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

(Resolved)HyperV Shared VHDX anyone using it with starwind ?

Public beta (bugs, reports, suggestions, features and requests)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

(Resolved)HyperV Shared VHDX anyone using it with starwind ?

Postby RaymondTH » Thu Apr 10, 2014 4:27 pm

edit Ok I figured out how to fix this issue, After searching the code online I found a post about someone trying to use this feature and getting the same error code with the vhds on the iscsi disks of a consumer nas which didn't support kerberos authentication.

Even though I had the cluster setup so the iscsi sync network was set to "do not allow cluster communication" and not used for live migration it was still trying to use this network for the shared vhdx.

The cause was the network binding order which had the iscsi nic above the server one. After putting the 10.0.0.x server adapter on top and rebooting no more messages appeared in the shared vhdx event log section and failover of the guest clusters worked.

Hope this helps anyone else who has this problem.
----

Hi ive been having an issue with my hyperv cluster on 2012 r2 with the latest starwind 8 RC and the new shared VHDX feature of server 2012 (This allows us to create guest clusters without installing mpio and setting up icsi on the guest nodes) I can create the cluster successfully but if any node is live migrated or the hyperv server restarts the failover doesn't work. The event log shows

Error attaching to volume. Volume: \Device\HarddiskVolumeShadowCopy4. Error: The specified request is not a valid operation for the target device..
Error opening handle for initiator. Initiator: {914c57ed-53a7-48fc-b5a8-edce7a25456b}. Hostname: HYPERV1. File: \SCFS QUORUM.VHDX:SHAREDVIRTUALDISK. Error: The request is not supported..

IP is as follows

HyperV 10.0.0.1,10.0.0.5,10.0.5.1,169.254.2.81 Online-
HYPERV1 10.0.0.1,10.0.0.5,10.0.5.1,169.254.2.81 Online
HYPERV2 10.0.0.2,10.0.5.2,169.254.1.91 Online

10.0.0.1 = HyperV1 Server IP (Teamed NC380T)
10.0.5.1 = (Teamed IPoIP)

Ethernet adapter Infiniband:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Network Adapter Multiplexor Driver #2
Physical Address. . . . . . . . . : 00-1A-4B-0C-02-21
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 10.0.5.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled

Ethernet adapter vEthernet (ServerNet):

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter #2
Physical Address. . . . . . . . . : 00-1C-C4-DF-92-FE
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 10.0.0.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IPv4 Address. . . . . . . . . . . : 10.0.0.5(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.0.0.20
DNS Servers . . . . . . . . . . . : 10.0.0.11
10.0.0.12
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 11:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Failover Cluster Virtual Adapter
Physical Address. . . . . . . . . : 02-BA-71-68-E8-DA
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 169.254.2.81(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled

and .2 for Hyperv2. I have also

Has anyone successfully got this feature to work on their starwind cluster ? Im not sure if its a starwind issue or a windows one.
RaymondTH
 
Posts: 3
Joined: Sat Oct 05, 2013 6:08 pm

Re: (Resolved)HyperV Shared VHDX anyone using it with starwind ?

Postby Bohdan (staff) » Mon Apr 14, 2014 8:38 am

Thank you for sharing this information!
User avatar
Bohdan (staff)
Staff
 
Posts: 435
Joined: Wed May 23, 2007 12:58 pm


Return to Public Beta

Who is online

Users browsing this forum: No registered users and 2 guests