StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

HostAgentFail On Add Storage Device in SCVMM 2012 Sp1 Beta

Public beta (bugs, reports, suggestions, features and requests)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

HostAgentFail On Add Storage Device in SCVMM 2012 Sp1 Beta

Postby lvnhjj » Wed Jan 16, 2013 8:46 am

Hi,ALL

I have been in this trouble for several days.Is there anyone can find a way to troubleshoot it.Pls advics.
My envirioument was installed the starwind native san for hyper v 6.0.0 with starwindsmis preview 0.6.1.
The server host the starwind software called srv01.lab.loc , and it's ip is 10.1.1.40.
I have once add this storage to vmm successfully, but i found the availiable capbilibity for this storage is alway zero and i can't assgin the resource to any host.
Then, i try to uninstall all above software. Unfortunately, Never success again.
Here is some configuration and error snap
QQ截图20130116161935.jpg
QQ截图20130116161935.jpg (24.07 KiB) Viewed 4277 times

vvvQQ截图20130116163225.jpg
vvvQQ截图20130116163225.jpg (26 KiB) Viewed 4291 times

QQ截图20130116161935.jpg
QQ截图20130116161935.jpg (24.07 KiB) Viewed 4277 times
Attachments
vvv2QQ截图20130116163312.jpg
vvv2QQ截图20130116163312.jpg (58.29 KiB) Viewed 4299 times
lvnhjj
 
Posts: 2
Joined: Wed Jan 16, 2013 8:29 am

Re: HostAgentFail On Add Storage Device in SCVMM 2012 Sp1 Beta

Postby lvnhjj » Thu Jan 17, 2013 8:32 am

Any Ideas?
I have tried to install the smi-provider and native san for hyper v in different host,But nothing changed.
:|
lvnhjj
 
Posts: 2
Joined: Wed Jan 16, 2013 8:29 am

Re: HostAgentFail On Add Storage Device in SCVMM 2012 Sp1 Beta

Postby Max (staff) » Fri Jan 18, 2013 5:28 pm

Hi!
Hang on, I'll ask our SMI-S guru developer to have a look at this.
Max Kolomyeytsev
StarWind Software
User avatar
Max (staff)
Staff
 
Posts: 533
Joined: Tue Apr 20, 2010 9:03 am

Re: HostAgentFail On Add Storage Device in SCVMM 2012 Sp1 Beta

Postby Max (staff) » Mon Jan 21, 2013 9:55 am

OK, I've got an update from our SMI-S developer:
1. The "HostAgentFail On Add Storage Device in SCVMM 2012 Sp1 Beta" message appears if an SSL connection can't be established.
This may happen if a system update KB2585542 is installed.
More information about the update can be found here:
http://operatingquadrant.com/2012/01/12 ... kb2585542/
http://social.technet.microsoft.com/For ... 7e1b550fd6
So if this is the case you need to either uninstall this update or do a registry modification (if you decide to go regedit way - let me know and I'll PM you the instructions)

2. In the version you're currently running SMI-S does not support LUN masking, thus it can not do "Assign to host". We already have a newer version which does it, however it it still in beta testing.
Please let me know if you'd like to give it a try, I would be happy to assist you in your testing.
Max Kolomyeytsev
StarWind Software
User avatar
Max (staff)
Staff
 
Posts: 533
Joined: Tue Apr 20, 2010 9:03 am

Re: HostAgentFail On Add Storage Device in SCVMM 2012 Sp1 Beta

Postby aweissmsft » Mon Feb 11, 2013 7:42 pm

Hey Max,

I would be interested in trying out the latest version of the SMI-S agent that you currently have in beta testing. I'm running into similar issues. Any chance I could grab a download link?

Thanks,
Andrew
aweissmsft
 
Posts: 2
Joined: Wed Jan 02, 2013 4:02 pm

Re: HostAgentFail On Add Storage Device in SCVMM 2012 Sp1 Beta

Postby Anatoly (staff) » Thu Feb 14, 2013 1:29 pm

Have you joined the beta testing program already? If not please use the link below:
http://www.starwindsoftware.com/beta-testing-program

We will update the build tomorrow (hopefully :) )
Best regards,
Anatoly Vilchinsky
Global Engineering and Support Manager
www.starwind.com
[email protected]
User avatar
Anatoly (staff)
Staff
 
Posts: 1675
Joined: Tue Mar 01, 2011 8:28 am


Return to Beta

Who is online

Users browsing this forum: No registered users and 3 guests