StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

VMM 2012 SMI-S

Public beta (bugs, reports, suggestions, features and requests)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

VMM 2012 SMI-S

Postby JoeHodkinson » Thu Jul 26, 2012 2:42 pm

Good afternoon all,

I have set-up a StarWind server (Free edition) and installed and I think configured the SMI-S software correctly - I did follow the guide.

When I try to add a storage device in the VMM 2012 console (not using SSL) I get to the 'Discover and import storage device information' page where the progress bar gets about 50% and sits there for around 15 - 20 seconds before the VMM console closes completely and tries to reconnect.

Has anyone else experienced this behaviour? I have tried this in 3 or 4 different setups, different machines etc. and always get the same!

Thanks, Joe
JoeHodkinson
 
Posts: 3
Joined: Thu Jul 26, 2012 2:34 pm

Re: VMM 2012 SMI-S

Postby Bohdan (staff) » Fri Jul 27, 2012 11:41 am

Please provide us more details about your config. Were StarWind, VMM and SMI-S provider installed on same machine?
If StarWind and SMI-S provider were installed on the same server, the hostname field of SMI-S configurator should be "localhost", else - you should specify the IP address of the StarWind server.
Also make sure that device path is the existing directory.
beta-f17/stawind-smi-provider-for-vmm-issue-t2807.html#p16301
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: VMM 2012 SMI-S

Postby JoeHodkinson » Fri Jul 27, 2012 2:27 pm

I have tried several different set-ups with the same result. Currently the SMS-I and StarWind software are installed on the same server with the VMM on a separate box. I have tried to add it from the VMM console on the VMM server and also a console installed on the StarWind server but both just exit and try to reconnect.

I have followed the instructions to the letter as far as I can see but please see my config which I have attached. As you can see I have set the path to My Computer\\D\\StarWind - I have created the directory | StarWind manually in the root of the D drive. Do you need to set any particular security on this folder?


Thanks,
Joe
Attachments
Capture.PNG
My SMI-S Config
Capture.PNG (36.55 KiB) Viewed 12422 times
JoeHodkinson
 
Posts: 3
Joined: Thu Jul 26, 2012 2:34 pm

Re: VMM 2012 SMI-S

Postby Yuriy (staff) » Mon Jul 30, 2012 8:33 am

Dear JoeHodkinson,

We need to know version of SC VMM that you use.
We'll try to reproduce this issue on that version.

--
Best regards,
Yuriy.
User avatar
Yuriy (staff)
Staff
 
Posts: 56
Joined: Fri Apr 13, 2012 12:14 pm

Re: VMM 2012 SMI-S

Postby JoeHodkinson » Mon Jul 30, 2012 8:49 am

Hello - the version is VMM 2012 SP1 CTP2 (version 3.1.3010.0). If you need any more info let me know.

Thanks, Joe
JoeHodkinson
 
Posts: 3
Joined: Thu Jul 26, 2012 2:34 pm

Re: VMM 2012 SMI-S

Postby Yuriy (staff) » Mon Jul 30, 2012 2:05 pm

JoeHodkinson wrote:Hello - the version is VMM 2012 SP1 CTP2 (version 3.1.3010.0). If you need any more info let me know.

Thanks, Joe


Joe,

It will be nice if you collect CIM-XML command tracing for us.
Look here for more information on how to get it ("Enable SCX CIM-XML command tracing" point):
http://blogs.technet.com/b/hectorl/archive/2011/12/08/scvmm-2012-collecting-storage-related-traces.aspx

Please, collect tracing for a moment of SC VMM service crash and some time before.

Thanks in advance!

--
Yuriy.
User avatar
Yuriy (staff)
Staff
 
Posts: 56
Joined: Fri Apr 13, 2012 12:14 pm


Return to Beta

Who is online

Users browsing this forum: No registered users and 3 guests