StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Stawind SMI-S Provider for VMM Issue

Public beta (bugs, reports, suggestions, features and requests)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Stawind SMI-S Provider for VMM Issue

Postby ericlaiys » Sat Jun 09, 2012 3:30 am

Hi,

i have tested use Starwind SMI-S Provider and put into VMM 2012. However, the pool indicated 0 size. Unless i create LUN in starwind iSCSI. Then the LUN is visible into VMM Storage. I can delete the LUN but cannot create a new LUN. Then i would like to see the pool at VMM and able to provision new LUN from VMM 2012 rather than go to starwind console. Any idea on how to achieve this?

Please advise. Thank you
ericlaiys
 
Posts: 7
Joined: Sat Jan 09, 2010 2:06 pm

Re: Stawind SMI-S Provider for VMM Issue

Postby anton (staff) » Sun Jun 10, 2012 1:01 pm

Zero size pool issue has been fixed in the most recent builds. What's revision one you're using now? Also I'm moving this one to Beta forum...
Regards,
Anton Kolomyeytsev

Chief Technology Officer & Chief Architect, StarWind Software

Image
User avatar
anton (staff)
Site Admin
 
Posts: 3922
Joined: Fri Jun 18, 2004 12:03 am
Location: British Virgin Islands

Re: Stawind SMI-S Provider for VMM Issue

Postby ericlaiys » Fri Jul 13, 2012 8:22 am

Hi,

Just downloaded the latest version and retry. But i'm still seeing as 0.

Using Starwind Native SAN for Hyper-V V5.8.0 (Build 20120607)

Please advise
ericlaiys
 
Posts: 7
Joined: Sat Jan 09, 2010 2:06 pm

Re: Stawind SMI-S Provider for VMM Issue

Postby Bohdan (staff) » Mon Jul 16, 2012 7:08 am

Do you follow the steps of the "StarWind SMI-S Agent: Storage Provider for SCVMM" manual?
http://www.starwindsoftware.com/starwin ... -for-scvmm

Please make sure you are specifying the existing directory for the "Device path" (page 9 of the manual) .
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: Stawind SMI-S Provider for VMM Issue

Postby ericlaiys » Fri Jul 20, 2012 1:48 am

Hi,
Yes. i did follow the manual. Ok, let double confirm on the device path
Scenario:-
My E Drive is empty without any files
Starwind SAN IP 192.168.88.127

a) specify "My Computer\\E\\
or b) specify "My Computer\\E\\pool

Both result still 0 storage capacity. For option (b), do i need to create pool file/target?

Another issue:- On the VMM provider i add the SMI-S provider using 192.168.88.127:5988. Managed to add in with SLL unchecked.
If i try 192.168.88.127:5989 using SSL. Failed to detect and take longer to detect.
I have follow step 9 to generate the certificate.
ericlaiys
 
Posts: 7
Joined: Sat Jan 09, 2010 2:06 pm

Re: Stawind SMI-S Provider for VMM Issue

Postby Bohdan (staff) » Fri Jul 20, 2012 7:52 am

1) Create "pool" directory on your E drive
2) Specify "My Computer\\E\\pool"

As for SSL, you must restart the machine with SMI-S provider. Page 9: "3. To complete the configuration process, restart your computer."
After that - Page 12: "8. During the discovery process you will be prompted to import the certificate. Click Import to continue."

BTW,
Starwind SAN IP 192.168.88.127 - does it mean that you installed SMI-S provider on the same machine as StarWind iSCSI SAN?
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: Stawind SMI-S Provider for VMM Issue

Postby ericlaiys » Thu Aug 02, 2012 4:48 am

Hi,


Yes. I have installed SMI-S provider into the same machine as Starwind iSCSI. Is that correct or i should install into another machine/vmm 2012.
btw, now i can see the total capacity.

Please advise

Thank you
ericlaiys
 
Posts: 7
Joined: Sat Jan 09, 2010 2:06 pm

Re: Stawind SMI-S Provider for VMM Issue

Postby Bohdan (staff) » Fri Aug 03, 2012 1:28 pm

Correct.

Is the server in domain? This case you should specify the full name.
Please make sure the name you are specifying during the SSL certificate generation is identical with the name which VMM shows (for example in error messages).
The fields "Issued to" and "Issued by" of the Import certificate dialog should be identical (Page 12 of the manual).
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: Stawind SMI-S Provider for VMM Issue

Postby Yuriy (staff) » Wed Aug 08, 2012 4:40 pm

ericlaiys wrote:Another issue:- On the VMM provider i add the SMI-S provider using 192.168.88.127:5988. Managed to add in with SLL unchecked.
If i try 192.168.88.127:5989 using SSL. Failed to detect and take longer to detect.
I have follow step 9 to generate the certificate.


Dear ericlaiys,

We have found that this issue can be concerned with security update KB2585542.
Read more here:
http://social.technet.microsoft.com/Forums/en-US/operationsmanagerunixandlinux/thread/ef611c9e-b36a-4d23-a680-de7e1b550fd6
http://operatingquadrant.com/2012/01/12/opsmgr-unixlinux-heartbeat-failures-after-applying-kb2585542/

Please, try to fix it that way.

Here is main part:
The OpsMgr UNIX/Linux monitoring team at Microsoft is currently investigating an issue that results in heartbeat failures on Operations Manager UNIX/Linux agents after the security update KB2585542 is applied to a Management Server or Gateway. This update fixes a vulnerability in SSL/TLS1.0, but appears to cause WS-Management connections to UNIX/Linux agents to fail.
The vulnerability is described in bulletin MS12-006, and more information can be found in the KB article. While we continue to investigate options for resolving this issue, there are two viable workarounds (which must be applied to all Mgmt Servers and Gateways that manage UNIX/Linux agents):

1. Uninstall the update KB2585542
2. Make a registry modification to disable the SecureChannel changes implemented in the update

Note: the registry modification described here and in the KB article effectively disables the security fix that the update implements, so the modified system is subject to the same vulnerability as an unpatched system.
Modifying the registry to disable the SecureChannel changes:
1. A “FixIt” package is available in the KB article under the Known Issues section that can be used to disable the security update
2. Alternatively, you can add the 32bit DWORD value:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\SendExtraRecord = 2
These changes take effect immediately and do not require a reboot.


--
Yuriy.
User avatar
Yuriy (staff)
Staff
 
Posts: 56
Joined: Fri Apr 13, 2012 12:14 pm


Return to Beta

Who is online

Users browsing this forum: No registered users and 3 guests