StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

Deduplication datastore inactive after san reboot

Public beta (bugs, reports, suggestions, features and requests)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Deduplication datastore inactive after san reboot

Postby DarkDiamond » Mon Apr 23, 2012 12:55 pm

Hello,

I just upgraded one of my SANs to the 5.9 beta (free edition). I originally had a deduplication lun and a standard lun attached to my home ESXi cluster using the most recent version of 5.8. After I upgraded the SAN (which of course involved a restart of Starwind), the standard lun became available after a short period of time in vCenter. However, the dedupe lun didn't come back online, and the VMs I had within it were not available to start. I tried rebooting vCenter to see if something was "stuck" - but that didn't help either. I'm able to see the device on each individual host, but not the datastore. If I select a host individually, I'm able to add the datastore back, either by "Keeping the existing signature" (which is basically a force mount), or by "Assigning a new Signature".

Should this have happened? I've had to reboot Starwind in the past and don't remember any issues like this? It also seems peculiar that it only affected the dedupe lun.

Thanks!
Chris
User avatar
DarkDiamond
 
Posts: 29
Joined: Sat Dec 31, 2011 5:57 pm

Re: Deduplication datastore inactive after san reboot

Postby Bohdan (staff) » Tue Apr 24, 2012 7:45 am

Hi Chris,

This is wrong behavior. We'll check what's wrong and fix it ASAP.
Thanks for letting us know about the problem!
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: Deduplication datastore inactive after san reboot

Postby Bohdan (staff) » Fri Apr 27, 2012 1:13 pm

We have found what's wrong. It is related to device serial id generation.
The problem will be fixed by the 5.9 release.
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: Deduplication datastore inactive after san reboot

Postby misabel » Tue May 01, 2012 9:10 pm

I've installed the beta version to try, is there a way to enable the deduplication feature? Everything else seems to be licensed with the beta key except this.

Thanks!

Mathieu
misabel
 
Posts: 5
Joined: Tue May 01, 2012 9:08 pm

Re: Deduplication datastore inactive after san reboot

Postby anton (staff) » Tue May 01, 2012 10:14 pm

Did you re-request new key or are you using old one from 5.8 eval? Do you see dedupe target as a listed option or is it grayed out?

misabel wrote:I've installed the beta version to try, is there a way to enable the deduplication feature? Everything else seems to be licensed with the beta key except this.

Thanks!

Mathieu
Regards,
Anton Kolomyeytsev

Chief Technology Officer & Chief Architect, StarWind Software

Image
User avatar
anton (staff)
Site Admin
 
Posts: 3922
Joined: Fri Jun 18, 2004 12:03 am
Location: British Virgin Islands

Re: Deduplication datastore inactive after san reboot

Postby misabel » Tue May 01, 2012 10:29 pm

There was a link in the 5.9 email to download the license key, that's the key file I used when activating. When I go to create a new device, Deduplicated disk device has a padlock next to it. At the bottom of the screen it says Items marked as (padlock icon) are not licensed. Please contact support http://<support url>
misabel
 
Posts: 5
Joined: Tue May 01, 2012 9:08 pm

Re: Deduplication datastore inactive after san reboot

Postby anton (staff) » Tue May 01, 2012 11:01 pm

Strange... We'll check keygen tool and I've dropped an e-mail to your account so you should receive new key ASAP. Sorry and thanks!

misabel wrote:There was a link in the 5.9 email to download the license key, that's the key file I used when activating. When I go to create a new device, Deduplicated disk device has a padlock next to it. At the bottom of the screen it says Items marked as (padlock icon) are not licensed. Please contact support http://<support url>
Regards,
Anton Kolomyeytsev

Chief Technology Officer & Chief Architect, StarWind Software

Image
User avatar
anton (staff)
Site Admin
 
Posts: 3922
Joined: Fri Jun 18, 2004 12:03 am
Location: British Virgin Islands

Re: Deduplication datastore inactive after san reboot

Postby Alex (staff) » Wed May 02, 2012 1:51 pm

Mathieu,
Beta license key has been updated, link is the same.
Thank you for the message and sorry for the mess-up!
Best regards,
Alexey.
User avatar
Alex (staff)
Staff
 
Posts: 177
Joined: Sat Jun 26, 2004 8:49 am


Return to Beta

Who is online

Users browsing this forum: Google [Bot] and 4 guests