StarWind iSCSI SAN
StarWind Native SAN for Hyper-V
 

StarWind V5.9/6.0 Beta

Public beta (bugs, reports, suggestions, features and requests)

Moderators: art (staff), anton (staff), Anatoly (staff), Max (staff)

Re: StarWind V5.9/6.0 Beta

Postby rarana » Tue Aug 14, 2012 11:22 pm

Hello,

Just got of the phone with Software Sales. i asked about the third node replication for disatar recovery and i was directed to the forums. My question is when is the plus 1 package suppose to be ready for testing? is this already part of the 6.0 beta? When trying to add a third node to an HA cluster, I cannot select the sync and heartbeat channles on third node. They are greyed out. The Cluster is on the SAME LAN, while the third node I am trying to add is on another routed LAN.

Thanks,

Rommel
rarana
 
Posts: 6
Joined: Tue Aug 14, 2012 11:02 pm

Re: StarWind V5.9/6.0 Beta

Postby Bohdan (staff) » Wed Aug 15, 2012 7:00 am

sammybendover wrote:
Bohdan (staff) wrote:
I appreciate that. Also, is there anything at this time you would like me or us to test specifically?

HA in 2 and 3 node modes under as high load as possible and as many scenarios as you can invent to break it. :)

Are there any plans to be able to use SSD for some additional caching like a ZIL or ARC in ZFS?

Yes. We are already working on it.


I only have the one file server, if I had two, I would love to be able to test HA iSCSI :)
I'll see what I have for funds, maybe I can bet up another server like this and have two of them.
Anything else I can test on standalone iSCSI server?


Deduplication, iSCSI diskless boot, ESX and Hyper-V backup
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: StarWind V5.9/6.0 Beta

Postby tkboyle » Wed Aug 15, 2012 7:39 am

tkboyle wrote:
Bohdan (staff) wrote:
tkboyle wrote:Hello again.
Performing a Daily Initial Incremental Backup of an offline VMware VM (Redhat 5.4 x86_64)
It appears to be failing with error 21012.

What does this code mean?
Below is the output from the hypervisor log file.


It is possible the BackupSnapshot-1911 snapshot was deleted.
Is there any other (backup?) software that could delete it?


There appears to lots of these "BackupSnapshot-1911" instances when viewed from vcenter.
The quantity of snapshots are the same amount of failed backups.

I have removed these snapshots to start from fresh although the result is the same.
The VM that I'm attempting to backup already has 12 snapshots associated with it.

I have also experienced this behavior on a snapshot free Windows 2008 R2 VM.


Yep still not having any joy backing up anything at the moment.

Code: Select all
14-08-2012 14:33:47 (1) Job: VM path:

14-08-2012 14:33:48 (1) Job: ESXi_Plugin.dll is a Source plugin

14-08-2012 14:33:48 (1) Job: Vmdk_Plugin.dll is a Target plugin

14-08-2012 14:33:48 (1) Starting ESXi backup...

14-08-2012 14:33:48 (1) Connecting to server 192.168.175.124 ...

14-08-2012 14:33:48 (1) Checking CBT...

14-08-2012 14:33:48 (1) CBT is enabled

14-08-2012 14:33:48 (1) Removing excess snapshots...

14-08-2012 14:33:48 (1) Creating snapshot...

14-08-2012 14:33:48 (1) Snapshot creation started...

14-08-2012 14:33:50 (1) Snapshot creation finished. Refcount = 1

14-08-2012 14:33:50 (1) Opening VM disk [datastore2_hyp01] GBDEVODB02_WM82/GBDEVODB02_WM82-000007.vmdk

14-08-2012 14:34:12 (1) Job: Writing machine info...

14-08-2012 14:34:12 (1) Job: Image copy operation has started...

14-08-2012 14:34:12 (1) Retrieving VM config from server...

14-08-2012 14:34:59 (1) ---Base image creation start for disk #0---

14-08-2012 14:34:59 (1) Snapshot changeID = 52 7e 28 69 67 09 0e 14-3f d3 ac 12 ba fe 79 d7/8

14-08-2012 14:34:59 (1) Failed to retrieve blocks with '*' ChangeID

14-08-2012 14:34:59 (1) Number of CBT blocks 1

14-08-2012 14:34:59 (1) Total size of backup data 156766306304

14-08-2012 14:34:59 (1) Disk copy started...

14-08-2012 15:06:10 (1) VixDiskLib_Read failed with VixError 1

14-08-2012 15:06:10 (1) Reconnecting disk...

14-08-2012 15:06:18 (1) Cannot open disk. VixError code 3

14-08-2012 15:06:18 (1) Disk read error 12

14-08-2012 15:06:18 (1) Job: BaseImage creation failed with code 21012

14-08-2012 15:06:18 (1) Job: Clean up...

14-08-2012 15:06:18 (1) Job failed with error 21012

14-08-2012 15:06:18 (1) Closing disk image

14-08-2012 15:06:18 (1) Job: Job ended with status 21012





14-08-2012 15:34:54 (2) Job: VM path:

14-08-2012 15:34:54 (2) Job: ESXi_Plugin.dll is a Source plugin

14-08-2012 15:34:54 (2) Job: Vmdk_Plugin.dll is a Target plugin

14-08-2012 15:34:54 (2) Starting ESXi backup...

14-08-2012 15:34:54 (2) Connecting to server 192.168.175.124 ...

14-08-2012 15:34:55 (2) Checking CBT...

14-08-2012 15:34:55 (2) CBT is enabled

14-08-2012 15:34:55 (2) Using existing snapshot. Refcount = 2

14-08-2012 15:34:55 (2) Opening VM disk [datastore2_hyp01] GBDEVODB02_WM82/GBDEVODB02_WM82-000007.vmdk

14-08-2012 15:35:15 (2) Job: Writing machine info...

14-08-2012 15:35:15 (2) Job: Image copy operation has started...

14-08-2012 15:35:15 (2) Retrieving VM config from server...

14-08-2012 15:35:16 (2) ---Base image creation start for disk #0---

14-08-2012 15:35:16 (2) Failed to retrieve changeID, using *

14-08-2012 15:35:16 (2) Snapshot changeID = *

14-08-2012 15:35:16 (2) Failed to retrieve blocks with '*' ChangeID

14-08-2012 15:35:17 (2) CBT info failed, whole disk will be back-upped

14-08-2012 15:35:17 (2) Number of CBT blocks 1

14-08-2012 15:35:17 (2) Total size of backup data 156766306304

14-08-2012 15:35:17 (2) Disk copy started...

14-08-2012 16:06:26 (2) VixDiskLib_Read failed with VixError 1

14-08-2012 16:06:26 (2) Reconnecting disk...

14-08-2012 16:06:55 (2) Cannot open disk. VixError code 3

14-08-2012 16:06:55 (2) Disk read error 12

14-08-2012 16:06:55 (2) Job: BaseImage creation failed with code 21012

14-08-2012 16:06:55 (2) Job: Clean up...

14-08-2012 16:06:55 (2) Job failed with error 21012

14-08-2012 16:06:55 (2) Closing disk image

14-08-2012 16:06:55 (2) Job: Job ended with status 21012





14-08-2012 20:30:24 (3) Job: VM path:

14-08-2012 20:30:24 (3) Job: ESXi_Plugin.dll is a Source plugin

14-08-2012 20:30:24 (3) Job: Vmdk_Plugin.dll is a Target plugin

14-08-2012 20:30:24 (3) Starting ESXi backup...

14-08-2012 20:30:24 (3) Connecting to server 192.168.175.124 ...

14-08-2012 20:30:24 (3) Checking CBT...

14-08-2012 20:30:24 (3) CBT is enabled

14-08-2012 20:30:24 (3) Removing excess snapshots...

14-08-2012 20:30:24 (3) Creating snapshot...

14-08-2012 20:30:24 (3) Snapshot creation started...

14-08-2012 20:30:26 (3) Snapshot creation finished. Refcount = 1

14-08-2012 20:30:26 (3) Opening VM disk [datastore2_hyp01] GBDEVTRANS03/GBDEVTRANS03.vmdk

14-08-2012 20:30:44 (3) Starting ESXi backup...

14-08-2012 20:30:44 (3) Connecting to server 192.168.175.124 ...

14-08-2012 20:30:44 (3) Checking CBT...

14-08-2012 20:30:44 (3) CBT is enabled

14-08-2012 20:30:44 (3) Using existing snapshot. Refcount = 2

14-08-2012 20:30:44 (3) Opening VM disk [datastore2_hyp01] GBDEVTRANS03/GBDEVTRANS03_1.vmdk

14-08-2012 20:30:47 (3) Job: Writing machine info...

14-08-2012 20:30:47 (3) Job: Image copy operation has started...

14-08-2012 20:30:48 (3) Retrieving VM config from server...

14-08-2012 20:30:49 (3) ---Base image creation start for disk #0---

14-08-2012 20:30:49 (3) Snapshot changeID = 52 a5 b5 27 61 7a e3 09-00 3b ff 62 be ac 0a 28/2

14-08-2012 20:30:49 (3) Number of CBT blocks 3

14-08-2012 20:30:49 (3) Total size of backup data 64222134272

14-08-2012 20:30:49 (3) Disk copy started...

14-08-2012 20:38:53 (3) VixDiskLib_Read failed with VixError 16007

14-08-2012 20:38:53 (3) Disk read error 12

14-08-2012 20:38:53 (3) Job: BaseImage creation failed with code 21012

14-08-2012 20:38:53 (3) Job: Clean up...

14-08-2012 20:38:54 (3) Job failed with error 21012

14-08-2012 20:38:55 (3) Closing disk image

14-08-2012 20:38:55 (3) Deleting snapshot...

14-08-2012 20:38:55 (3) Snapshot refcount 1

14-08-2012 20:38:58 (3) Closing disk image

14-08-2012 20:38:58 (3) Deleting snapshot...

14-08-2012 20:38:58 (3) Snapshot refcount 0

14-08-2012 20:38:58 (3) Snapshot deletion started...

14-08-2012 20:38:59 (3) Snapshot deletion finished

14-08-2012 20:38:59 (3) Job: Job ended with status 21012





14-08-2012 20:47:06 (4) Job: VM path:

14-08-2012 20:47:06 (4) Job: ESXi_Plugin.dll is a Source plugin

14-08-2012 20:47:06 (4) Job: Vmdk_Plugin.dll is a Target plugin

14-08-2012 20:47:06 (4) Starting ESXi backup...

14-08-2012 20:47:06 (4) Connecting to server 192.168.175.124 ...

14-08-2012 20:47:06 (4) Checking CBT...

14-08-2012 20:47:06 (4) CBT is disabled. Enabling...

14-08-2012 20:47:07 (4) CBT is enabled

14-08-2012 20:47:07 (4) Removing excess snapshots...

14-08-2012 20:47:07 (4) Creating snapshot...

14-08-2012 20:47:07 (4) Snapshot creation started...

14-08-2012 20:47:53 (4) Snapshot creation finished. Refcount = 1

14-08-2012 20:47:53 (4) Opening VM disk [ISCSI_datastore1] GBDEVWIND384/Test VM TB2-000001.vmdk

14-08-2012 20:48:11 (4) Starting ESXi backup...

14-08-2012 20:48:11 (4) Connecting to server 192.168.175.124 ...

14-08-2012 20:48:11 (4) Checking CBT...

14-08-2012 20:48:11 (4) CBT is enabled

14-08-2012 20:48:11 (4) Using existing snapshot. Refcount = 2

14-08-2012 20:48:11 (4) Opening VM disk [ISCSI_datastore1] GBDEVWIND384/GBDEVWIND384.vmdk

14-08-2012 20:48:14 (4) Job: Writing machine info...

14-08-2012 20:48:14 (4) Job: Image copy operation has started...

14-08-2012 20:48:15 (4) Retrieving VM config from server...

14-08-2012 20:48:16 (4) Job: Failed to retrieve ESXi VM config. Error code 21000

14-08-2012 20:48:16 (4) Job: Clean up...

14-08-2012 20:48:16 (4) Job failed with error 21000

14-08-2012 20:48:16 (4) Closing disk image

14-08-2012 20:48:16 (4) Deleting snapshot...

14-08-2012 20:48:16 (4) Snapshot refcount 1

14-08-2012 20:48:17 (4) Closing disk image

14-08-2012 20:48:17 (4) Deleting snapshot...

14-08-2012 20:48:17 (4) Snapshot refcount 0

14-08-2012 20:48:17 (4) Snapshot deletion started...

14-08-2012 21:01:29 (4) Snapshot deletion finished

14-08-2012 21:01:29 (4) Job: Job ended with status 21000





15-08-2012 07:56:40 (5) Job: VM path:

15-08-2012 07:56:40 (5) Job: ESXi_Plugin.dll is a Source plugin

15-08-2012 07:56:40 (5) Job: Vmdk_Plugin.dll is a Target plugin

15-08-2012 07:56:40 (5) Starting ESXi backup...

15-08-2012 07:56:40 (5) Connecting to server 192.168.175.124 ...

15-08-2012 07:56:40 (5) Checking CBT...

15-08-2012 07:56:40 (5) CBT is enabled

15-08-2012 07:56:40 (5) Using existing snapshot. Refcount = 3

15-08-2012 07:56:40 (5) Opening VM disk [datastore2_hyp01] GBDEVODB02_WM82/GBDEVODB02_WM82-000007.vmdk

15-08-2012 07:57:00 (5) Job: Writing machine info...

15-08-2012 07:57:00 (5) Job: Image copy operation has started...

15-08-2012 07:57:01 (5) Retrieving VM config from server...

15-08-2012 07:57:02 (5) ---Base image creation start for disk #0---

15-08-2012 07:57:02 (5) Failed to retrieve changeID, using *

15-08-2012 07:57:02 (5) Snapshot changeID = *

15-08-2012 07:57:02 (5) Failed to retrieve blocks with '*' ChangeID

15-08-2012 07:57:02 (5) CBT info failed, whole disk will be back-upped

15-08-2012 07:57:02 (5) Number of CBT blocks 1

15-08-2012 07:57:02 (5) Total size of backup data 156766306304

15-08-2012 07:57:02 (5) Disk copy started...

15-08-2012 08:29:28 (5) VixDiskLib_Read failed with VixError 1

15-08-2012 08:29:28 (5) Reconnecting disk...

15-08-2012 08:29:53 (5) Cannot open disk. VixError code 3

15-08-2012 08:29:53 (5) Disk read error 12

15-08-2012 08:29:53 (5) Job: BaseImage creation failed with code 21012

15-08-2012 08:29:53 (5) Job: Clean up...

15-08-2012 08:29:53 (5) Job failed with error 21012

15-08-2012 08:29:53 (5) Closing disk image

15-08-2012 08:29:53 (5) Job: Job ended with status 21012





14-08-2012 12:30:14 (0) Service started. x64 service ver. Current version 2.2.1.1875  Stable API version 2.2.1.1775 (Aug  9 2012, 11:56:43). Running on x64 OS

14-08-2012 12:30:14 (0) Warning! There is no HyperV installed on this machine

14-08-2012 12:30:14 (0) Service is running

14-08-2012 12:46:30 (0) Shutdown Event Raised

14-08-2012 12:46:30 (0) Shutdown complete





14-08-2012 12:48:36 (0) Service started. x64 service ver. Current version 2.2.1.1875  Stable API version 2.2.1.1775 (Aug  9 2012, 11:56:43). Running on x64 OS

14-08-2012 12:48:41 (0) Warning! There is no HyperV installed on this machine

14-08-2012 12:48:41 (0) Service is running

14-08-2012 14:26:32 (0) StopEvent Raised

14-08-2012 14:26:37 (0) Shutdown complete





14-08-2012 14:26:45 (0) Service started. x64 service ver. Current version 2.2.1.1875  Stable API version 2.2.1.1775 (Aug  9 2012, 11:56:43). Running on x64 OS

14-08-2012 14:26:45 (0) Warning! There is no HyperV installed on this machine

14-08-2012 14:26:45 (0) Service is running

14-08-2012 14:27:32 (0) StopEvent Raised

14-08-2012 14:27:37 (0) Shutdown complete





14-08-2012 14:28:25 (0) Service started. x64 service ver. Current version 2.2.1.1875  Stable API version 2.2.1.1775 (Aug  9 2012, 11:56:43). Running on x64 OS

14-08-2012 14:28:25 (0) Warning! There is no HyperV installed on this machine

14-08-2012 14:28:25 (0) Service is running

14-08-2012 14:33:47 (0) Distor Service: Job file received

14-08-2012 14:33:47 (0) Distor Service: Job start initiated

14-08-2012 15:34:54 (0) Distor Service: Job file received

14-08-2012 15:34:54 (0) Distor Service: Job start initiated

14-08-2012 20:30:24 (0) Distor Service: Job file received

14-08-2012 20:30:24 (0) Distor Service: Job start initiated

14-08-2012 20:47:06 (0) Distor Service: Job file received

14-08-2012 20:47:06 (0) Distor Service: Job start initiated

15-08-2012 07:56:40 (0) Distor Service: Job file received

15-08-2012 07:56:40 (0) Distor Service: Job start initiated

tkboyle
 
Posts: 9
Joined: Tue Aug 14, 2012 10:08 am

Re: StarWind V5.9/6.0 Beta

Postby Bohdan (staff) » Wed Aug 15, 2012 8:39 am

rarana wrote:Hello,

Just got of the phone with Software Sales. i asked about the third node replication for disatar recovery and i was directed to the forums. My question is when is the plus 1 package suppose to be ready for testing? is this already part of the 6.0 beta? When trying to add a third node to an HA cluster, I cannot select the sync and heartbeat channles on third node. They are greyed out. The Cluster is on the SAME LAN, while the third node I am trying to add is on another routed LAN.

Thanks,

Rommel


HA with remote replication can be configured when one of HA disks is deduplicated disk device with replica.
In management console it is necessary to select "Create HA from device" option and either select existing DD device with replica or create new one.
Attachments
Clipboard-1.jpg
Clipboard-1.jpg (42.54 KiB) Viewed 7064 times
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: StarWind V5.9/6.0 Beta

Postby rarana » Wed Aug 15, 2012 6:52 pm

Thank you very much.

Rom
rarana
 
Posts: 6
Joined: Tue Aug 14, 2012 11:02 pm

Re: StarWind V5.9/6.0 Beta

Postby rarana » Wed Aug 15, 2012 8:08 pm

Ok, I am not understanding exactly how to do this. is there step by step docuemntaion availbe that i can read on how to create a depulicated disk, replica set, where to store these and so on so that my end result is at Site A i have a two node HA cluster, and at site B i have a replicated HA cluster data availvle?

Thanks,

Rom
rarana
 
Posts: 6
Joined: Tue Aug 14, 2012 11:02 pm

Re: StarWind V5.9/6.0 Beta

Postby Bohdan (staff) » Thu Aug 16, 2012 3:40 pm

rarana wrote:Ok, I am not understanding exactly how to do this. is there step by step docuemntaion availbe that i can read on how to create a depulicated disk, replica set, where to store these and so on so that my end result is at Site A i have a two node HA cluster, and at site B i have a replicated HA cluster data availvle?

Thanks,

Rom

Please follow instructions from this guide
http://starwindsoftware.com/tmplink/Sta ... yper-V.pdf
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: StarWind V5.9/6.0 Beta

Postby rarana » Thu Aug 16, 2012 8:04 pm

Thank you for the instrcutions. I am having another issue. In the instructions CONFIGURING SHARED STORAGE on Step 10 where it says target for Data the target name never appears no matter how long i wait or if i click refresh many times. i am testing with Server 2003, do i need server 2008 or 2008 R2? i am able to initate the target from Microsoft iSCSI iniator but from that part in step 10 it never populates.

Thanks,

Rom
rarana
 
Posts: 6
Joined: Tue Aug 14, 2012 11:02 pm

Re: StarWind V5.9/6.0 Beta

Postby Bohdan (staff) » Fri Aug 17, 2012 12:28 pm

rarana wrote: i am able to initate the target from Microsoft iSCSI iniator but from that part in step 10 it never populates.

Thanks,

Rom

Are you talking about MS iSCSI initiator installed on the StarWind machine?
We need StarWind logs from the machine where you are trying to create DD device with replica. Please send it to [email protected] e-mail.
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: StarWind V5.9/6.0 Beta

Postby rarana » Fri Aug 17, 2012 6:40 pm

Yes, initator from MS iSCSI but in step 10 it is asking me to chose a target but nothing ever populates. how can i get logs for you?

-Rom
rarana
 
Posts: 6
Joined: Tue Aug 14, 2012 11:02 pm

Re: StarWind V5.9/6.0 Beta

Postby Vavaga » Sat Aug 18, 2012 5:08 am

Hello! Do you have manuals for v6 StarWind iSCSI HA for vSphere 5? Where can i get it? Espeshially interesting Backup for ESXi server. Thank you in advance.
Vavaga
 
Posts: 14
Joined: Mon Jun 11, 2012 5:50 am

Re: StarWind V5.9/6.0 Beta

Postby Bohdan (staff) » Mon Aug 20, 2012 7:28 am

rarana wrote:Yes, initator from MS iSCSI but in step 10 it is asking me to chose a target but nothing ever populates. how can i get logs for you?

-Rom

I mean you are talking about the initiator on the same machine as StarWind Service. Right?
You can find the logs in C:\Program Files\StarWind Software\StarWind\logs directory.
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: StarWind V5.9/6.0 Beta

Postby Bohdan (staff) » Mon Aug 20, 2012 7:33 am

Vavaga wrote:Hello! Do you have manuals for v6 StarWind iSCSI HA for vSphere 5? Where can i get it? Espeshially interesting Backup for ESXi server. Thank you in advance.

Hi
Right now unfortunately no. It is being updated.
We have the one for v5.8
http://www.starwindsoftware.com/providi ... or-vsphere
the difference is that HA creation wizard was a little changed. The other steps are the same.

I believe it will be ready in a week.
User avatar
Bohdan (staff)
Staff
 
Posts: 437
Joined: Wed May 23, 2007 12:58 pm

Re: StarWind V5.9/6.0 Beta

Postby tkboyle » Mon Aug 20, 2012 8:02 am

Any news on my reported issues.

At the moment I've had to stop testing as It's not working at all.
tkboyle
 
Posts: 9
Joined: Tue Aug 14, 2012 10:08 am

Re: StarWind V5.9/6.0 Beta

Postby blueninja » Tue Aug 21, 2012 4:17 pm

Bohdan (staff) wrote:
blueninja wrote:Will this new version allow for a diskless boot via PXE Boot (non-iSCSI client/initiator)?

The quick start guide is available from the following link:
http://starwindsoftware.com/tmplink/Sta ... SIBoot.pdf

The documentation appears to suggest, as does our testing, that we need to have some form of MS DCHP running on the target machine. We're trying to set up a peer-to-peer diskless boot between two Windows 7 machines.
blueninja
 
Posts: 6
Joined: Thu Aug 09, 2012 7:24 pm

PreviousNext

Return to Beta

Who is online

Users browsing this forum: No registered users and 1 guest